Pi Zero 2 Devbuild Update to 7.9.1 Kills Net

Pi Zero 2 running on Dev Channel.

When i log in i get the message to update from 7.8 to 7.9.1

So i run Dietpi-update and as soon as it starts it kills the net connection until i reboot.

Cannot submit a bug report via the launcher as obviously no network

DietPi-Update
─────────────────────────────────────────────────────
 Phase: Checking for available DietPi update

[  OK  ] DietPi-Update | Checking network connectivity
[  OK  ] DietPi-Update | Checking DNS resolver
[  OK  ] Network time sync | Completed
[ INFO ] DietPi-Update | Getting latest version from: https://raw.githubusercontent.com/MichaIng/DietPi/dev/.update/version
[  OK  ] DietPi-Update | Got valid latest version: 7.9.-1
[  OK  ] DietPi-Update | Update available:
[ INFO ] DietPi-Update | Current version : v7.8.-1
[ INFO ] DietPi-Update | Latest version  : v7.9.-1

 DietPi-Update
─────────────────────────────────────────────────────
 Phase: Checking for update pre-requirements

[  OK  ] DietPi-Update | DietPi-Userdata validation: /mnt/dietpi_userdata
[  OK  ] DietPi-Update | Free space check: path=/ | available=25276 MiB | required=100 MiB
[ SUB1 ] DietPi-Services > stop
[  OK  ] DietPi-Services | stop : cron
[  OK  ] DietPi-Services | stop : docker

 DietPi-Update
─────────────────────────────────────────────────────
 Phase: Applying pre-patches

[FAILED] DietPi-Update | Downloading pre-patches
 - Command: curl -sSfLO https://raw.githubusercontent.com/MichaIng/DietPi/dev/.update/pre-patches
[  OK  ] DietPi-BugReport | Downloading pre-patches
[  OK  ] DietPi-BugReport | Packing upload archive
[FAILED] DietPi-BugReport | Sending bug report

Is that by purpose you are running dev channel?

What is running inside docker?

Because i was testing the overclocking ability before you released it officially for the pi zero 2, originally was on the Zero channel but that got removed, and the updates there where included into the dev channel, so switched to dev channel and not changed it back to stable yet thats all

Nothing is running in docker, i have to remove that i was testing Home Assistant at some point and still dont like it so i removed it but not docker will do that now

Pls can you share what you are running on docker?

Sorry i just added an update to my previous post, nothing is running in docker i am removing docker now

Ok was just an idea if there was running something like a DNS server that got stopped during update.

Usually the update is not stopping any network connection. Can you still login one the connection failed? Is it just internet or as well local connection?

Interestingly enough, i try to uninstall docker with their uninstall command and it comes back saying it is not installed lol, however containerd is showing in btop

Only thing running is Adguard but thats not via docker.

When it fails, i have to reboot the device and then its back up and running

Still the question, once update failed are you able to access the system still locally or is SSH access lost as well? Could you share following

cat /etc/resolv.conf

no ssh stays active, but i wouldnt worry about it now, i just purged docker and the whole thing has gone dead, so a perfect excuse to just flash a fresh image from stable branch

You simply could change from dev branch to master. That’s not an issue. once you lost internet connection, check if you can ping an IP and a DNS name on the internet

ping 8.8.8.8
ping google.com

No it cannot ping after the update, but it sure cant ping now makes mental not not to autoclean without checking whats it’s autocleaning lol

Okay

Solved both problems in one hit.

checked /etc/resolv.conf and nameserver was set to the pizero2 itself (most likely as the Unifi Dream machine was pointing to this pi for adguard). Just set that to 1.1.1.1 to test

Result - Network back up
Update completes fine

I did check adguard to see if it was blocking github for any reason but it was not, however both issues resolved

This was my thought as well, that it a DNS issue most likely. Therefore ping to 8.8.8.8 should have succeeded. I guess AGH service has been stopped on update process. Anyway it’s not recommend to use localhost as DNS resolver on the Pi itself. Because exactly of this :wink:

Yeah makes sense, i just setup a new Pi4 today and moved the AGH to that and set the local resolver to 1.1.1.1, so will move the Pi Zero to a homemade stream deck setup when i get the touchscreen