Pi is running hot is there a way to debug what's causing it?

I set up DietPi yesterday on a pi 3B with plex and using an external drive for my music. Everything is running fine but when I just sshed to it I can see the message:

Architecture | armv7l
Temperature | WARNING: 73’C : 163’F (Reducing the life of your device)
Governor | ondemand
Throttle up | 50% CPU usage

Current Freq Min Freq Max Freq
CPU0 | 1300 MHz 600 MHz 1300 MHz
CPU1 | 1300 MHz 600 MHz 1300 MHz
CPU2 | 1300 MHz 600 MHz 1300 MHz
CPU3 | 1300 MHz 600 MHz 1300 MHz

Nothing is being played or scanned on plex, I’ve just unmounted the HDD (The light was flashing like it was being used) but the temp is still the same, is there a command I can run to see what’s running that could be causing it to get hot?

The pi is just in an official case, currently I’ve got the top off the case, it’s also got some of those little heatsinks, the room it’s in isn’t hot.

you could use htop to watch running processes. As well, if you are using the official case, you might think on the official RPi fan https://www.raspberrypi.org/products/raspberry-pi-4-case-fan/

At least from technical point of view, it’s working. But I’m not sure if it is fitting into a RPi3B case.

#dietpi-config

Performance tab, change from on demand to conservative

Changing from on demand to conservative, the CPU will slowly ramp up the CPU frequency if the processor usage drops instead of running wide open then throttle down to almost none, however if something is hammering the CPU it won’t help because the CPU ramps up and runs hot when it’s at high utilization.

for Plex it’s gonna run the CPU hard…best to get heatsink and active cooling to keep the heat down for sure

as Joulinar said…htop is going to be your best bet to see what thread is chewing on the CPU

there are a couple good cases out. As well there are fans having active control to avoid spinning all the time. Or some of the passive cooling cases. Plenty of options :wink:

Thanks for the replies, I had a look at htop and it was plex, I think it was plex scanning my music, because it was a new build it was scanning all my music which is over 500GB.

I have another pi set up the same and that streams video but never gets above 46 / 47. I compared the settings this morning and the only difference was on the hot running pi I hadn’t set plex to run the scanner at a lower priority.

Is this still something you would recommend I do?

change from on demand to conservative

I’ll make the change on both of my Pi’s if it’s worth it.

maybe it stop once plex finished scanning the disk. Or is it running on high load all the time

If it is still running to hot, just reduce ARM Temp Limit to 65 or 60 using dietpi-config 4

Yes, once it’s done going thru and scanning and building the database and whatnot it should idle down to a lower CPU usage