Pi 3B+ CPU governor/frequency readout not working?

Ah sorry, I accidentally looked at the “armv7l” contained in Joulinar’s .hw_model output, but you found the solution already :slight_smile:.

So then it is an issue with the latest kernel. Can you report this to RPi kernel devs, please: https://github.com/raspberrypi/linux/issues

I did some more testing on it and it seems to be fixed on next LTS kernel already

current version 5.10.92

root@DietPi3:~# uname -a
Linux DietPi3 5.10.92-v8+ #1514 SMP PREEMPT Mon Jan 17 17:39:38 GMT 2022 aarch64 GNU/Linux
root@DietPi3:~# journalctl -u dietpi-preboot.service
-- Journal begins at Mon 2022-02-07 09:42:20 CET, ends at Mon 2022-02-07 09:56:59 CET. --
Feb 07 09:42:22 DietPi3 systemd[1]: Starting DietPi-PreBoot...
Feb 07 09:42:22 DietPi3 DietPi-PreBoot[363]: DietPi-CPU_set | CPU governors are not available on this system. This is probably a virtual machine. Aborting...
Feb 07 09:42:22 DietPi3 systemd[1]: Finished DietPi-PreBoot.
root@DietPi3:~#

Next LTS version 5.15.18

root@DietPi3:~# uname -a
Linux DietPi3 5.15.18-v8+ #1520 SMP PREEMPT Fri Feb 4 12:04:45 GMT 2022 aarch64 GNU/Linux
root@DietPi3:~# journalctl -u dietpi-preboot.service
-- Journal begins at Mon 2022-02-07 10:31:17 CET, ends at Mon 2022-02-07 10:32:01 CET. --
Feb 07 10:31:19 DietPi3 systemd[1]: Starting DietPi-PreBoot...
Feb 07 10:31:19 DietPi3 DietPi-PreBoot[366]:  DietPi-CPU_set
Feb 07 10:31:19 DietPi3 DietPi-PreBoot[366]: ─────────────────────────────────────────────────────
Feb 07 10:31:19 DietPi3 DietPi-PreBoot[366]:  Mode: Applying CPU governor settings: ondemand
Feb 07 10:31:19 DietPi3 DietPi-PreBoot[366]: [ INFO ] DietPi-CPU_set | Setting up_threshold: 50 %
Feb 07 10:31:19 DietPi3 DietPi-PreBoot[366]: [ INFO ] DietPi-CPU_set | Setting sampling_rate: 25000 microseconds
Feb 07 10:31:19 DietPi3 DietPi-PreBoot[366]: [ INFO ] DietPi-CPU_set | Setting sampling_down_factor: 40 x
Feb 07 10:31:19 DietPi3 DietPi-PreBoot[366]: [  OK  ] DietPi-CPU_set | Applied CPU governor settings: ondemand
Feb 07 10:31:19 DietPi3 systemd[1]: Finished DietPi-PreBoot.
root@DietPi3:~#

That’s good to know!
I filed a bug report but it doesn’t seem to affect everyone with a Pi 3B+ which is odd.

But the bug must have been recognized at some point if it was fixed in the next kernel…

I have answered on RPI GitHub. https://github.com/raspberrypi/linux/issues/4875

Seems an alternative to downgrading the Kernel is to remove initial_turbo=20 from config.txt, or enter 0 for initial turbo in Dietpi-Config.
Once I did this and rebooted, CPU governor works even with the 5.10.92 Kernel.

let’s what RPI devs will find out.

Was anyone with an ARMv7 kernel affected btw, or ARMv8/64-bit systems only? I want to ship a live patch, to have commented the initial turbo setting until it a new kernel has been released which is not affected anymore. But makes sense to only apply it where really required.

I killed my ARMv6 installation this evening. Need to re-flash. I can do testing tomorrow during day time for ARMv6/7 images on RPi3B+.

had a little time to test this some more today… seems to be resolved on current firmware


boot-DAT-ELF_20220115_175984a6dc4c321553e295cf9679a6020231caf4/ GOOD
boot-DAT-ELF_20220117_20c5829b0afe5b99d7e807ce90c382bd6997993f/ NOTGOOD<PROBLEM
boot-DAT-ELF_20220118_3f20b832b27cd730deb6419b570f31a98167eef6/ STILLNOTGOOD
boot-DAT-ELF_20220121_827fdd073638fa7b7292d1148fe0af7465111eae/ STILLNOTGOOD
boot-DAT-ELF_20220125_9c04ed2c1ad06a615d8e6479806ab252dbbeb95a/ GOOD>FIXED
boot-DAT-ELF_20220128_e5013c9d596e1a392e5193bc8cb822966b9c7d7c/ GOOD
boot-DAT-ELF_20220219_a6496ae5cd5e9b4cd5b38f7274fa94dce315fa7a/ GOODCURRENT

linked issue from the commit which fixed it…

https://github.com/raspberrypi/firmware/issues/1688

at least it’s not dedicated to a DietPi issue. But good it will/was solved upstream.