OrangePi Zero Plus2 H5 WiFi issue


Yesterday i’ve downloaded and installed image by this link: REMOVED INVALID URL

After installing i could make wifi work. But after running apt-get upgrade to build 156 wifi got broken and doesn’t function now.

Any ideas how can i fix this? May be there is a way to downgrade to another build?

And are there any news on when this issue could be fixed?

Thank you!

And one more question - how to move system from sd to emmc?

This issue also effects me. I am jut loaded DietPi on my OrangePi Zero Plus 2 H5. On initial boot, I was able to successfully configure the WIFI and updated the software and installed some packages. Somewhere along the way, the WIFI ceased working. Now, when I try to configure WIFI, DietPi-Config states that there is no WIFI interface present.

I wiped the micro SD card, and copies the img file across again. Booted and went through the same process, and got a repeat of the above problem. WIFI ceases to be identified by DietPi-Config.

If there’s some additional information that I need to supply to enable someone to diagnose this issue further, please let me know.


Roy Gilby

The same to me… installed today, wifi working, autoupdate from 150 to 157, wifi still wording… install samba… wifi ko… solved using a wifi usb dongle, but internal wifi no more recognized. I think its too soon to buy a Zero P2 H5… it’s still quite unusable… and its a very “strange” board… not very intelligent configuration… no lan onboard??? no usb connectors??? the only usb present is for power??? …not very useful for any server issue… wifi is not very fast… bah… i think i have done a wrong purchase… :frowning:

PS: used 2A power supply with a good cable… maybe this board need more power… i’ll check consumption with my usb amperometer…

After some testing last night, I believe that the WIFI unreliability problem is power supply related. When the board was fed 5 Volts from my Bench Power Supply, the whole board, including WIFI, was quite reliable. When connected to a Samsung branded USB Charger that is rated at 2 amps, WIFI was unreliable. When connected to a no-name brand 2 amp USB Charger from China, the board re-booted the moment that the WIFI was enabled. But, an ammeter showed that the current draw was under 2 amps, so the 2 Amp charger should be OK.

However, when I used my Oscilloscope to look at the DC voltage being supplied to the board, I was able to capture brief periods of time (i.e. under 100 to 200 mSec) when the supply voltage dipped from 5.1 down to around 4.8 volts. These dips in the supply voltage seem to correspond to the commencement of WIFI Transmissions. I think the answer is that when the WIFI transmission commences, there is a brief high current draw, which on some not so well engineered USB Power supplies, results in the 5 volt supply briefly dropping low enough for the board to malfunction, or with some cheap USB Power Supplies, the board will reboot.

There are plenty of recommendations on various forums related to these devices that recommend a good quality USB power supply of at least 3 amps. Today, I bought a 3 Amp rated USB Charger. (It is made in China, with a local Australian brand name on it, so not much point in my providing the model number etc.) The 3 Amp USB Charger works well, and does not have any WIFI problems, and no re-boots.

As far as the lack of USB ports on the OrangePi Zero Plus2 H5 … When I bought my board, I bought the recommended add-on board that plugs on top and provides 2 USB ports, a microphone, audio socket, and I/R Receiver. Only costs about AU$ 5:00 inc postage, so a nice low cost solution.

I hope that info helps.


hummm. more power supply tests… using my usb testers result thet H5 uses less than 0.5A, with some peek to 600 mA… so a 3A supply is not needed… it must be sufficient a good 1A supply… I tried with a “good” supply (the supply of Kindle Fire) and the problem is the same: wifi worsk fine, untill the very end of installation (with needed applications)… thena after the4 “last” reboot wifi stop workin.
This week end i’ll make a good 3A supply with a good regolator and test again… at the moment i havent any 3A supply at home.

PS: using the “onboard” Android Distribution Wifi works fine with an old smartphone 500mA power supply… :wink:
the same (it works fine) using other distributions like Debian Jessie or Ubuntu Xenial…

I also have a similar problem.

upgraded without a problem.
installed lxde and the wifi stopped working.