Orange Pi 5 Plus - ZWAVE Stick not recognized in HASS


new to this…

  • Orange Pi 5 Plus
  • Zooz 800 Zwave Stick - ZST39LR
  • OPI5+ Power Supply (30w) - so not a power issue
  • DietPi_OrangePi5Plus-ARMv8-Bookworm

Installed Homeassistant through Dietpi-Software

Zigbee USB stick is recognized correctly, but the above mentioned ZWAVE stick is not.

Using the exact same setup on a RasPI3B works perfectly fine.

I ran into the same issue when installing HASS via Docker trying some other Distros, so this must be related. Was hoping Dietpi with its “software store” eliminates this issue, but no go.

When trying to add ZWave in HASS the stick is not recognized and adding it manually all I see is ws://localhost:3000.

Am I missing something? Or is that a Docker Issue? Again, had the same problem with that particular stick and Docker with another distro as well. And no issue on Raspian on a RasPi3B.

Thank you

Required Information

  • DietPi version | Latest
  • Distro version | Latest
  • Kernel version | Latest

Additional Information (if applicable)

  • Software title | Homeassistant
  • Was the software title installed freshly or updated/migrated? Fresh install
  • Can this issue be replicated on a fresh installation of DietPi? Yes, fresh install, tried twice

Expected behaviour

Plug in stick and HASS should detect the stick. Or by manually adding ZWAVE_JS should automatically detect the stick and I should be able to configure.

Actual behaviour

Stick is not found and the window only shows

Probably your stick is not able to run on OrangePi SBC? I guess missing kernel, overlay or driver support. You can’t compare it with RPI as it’s complete different SDC family running different kernel aso.

When I run LUSB the ZWAVE is recognized and detected correctly.
It’s just isolated and doesn’t get detected by HASS on DietPI.

Doesn’t that eliminate a Kernel-related issue? Again, LINUX novice here.

And you are running HA within Docker?

Not 100% sure.
How does DietPi install it when one picks the install through Softy/ DietPi’s Software library?

We install HA Core Python version.