Odroid XU4 - Fresh Installaion - Bootingproblem

Hey there,

thx again for the amazing work with DietPi - loving it.

I did a fresh installation of DietPi on my XU4. Everything was fine. But a strange error occurs:

Whenever I did a reboot (or the system cause of a sw-installation) the system isn’t booting. I see no informaion on the cloudshell-lcd ether. When I do a Ctr-Alt-Del to force a reboot after hanging everything is fine: the XU4 is booting and the LCD is working as well.

But I want to use the XU4 as headless server and so the actual attached keyboard (to do the reboot-command) has to go.

Does anyone else has/had this problem. I couldn’t find any similar topic.

Thx for helping.

mike

mike175de
Thanks for your report.

Hmm, not sure if the lcd displays all boot messages from start up. Could you try to attach an HDMI monitor and check for error messages there?

Also check your journalctl and/or dmesg to check boot logs. This will not show messages from the hang boot attempt, but maybe some warning/error message could still give a hint.

Also it would be possible to disable dietpi-ramlog and either install rsyslog or enable persistent journald logging by simple creating /var/log/journal folder: sudo mkdir /var/log/journal
With this you are able to check boot messages from the hang boot attempt.
Check journalctl respectively /var/log/syslog and /var/log/dietpi-boot.log then.

Btw feel free to raise an issue on GitHub, where at least Fourdee and me are around more regularly :wink:: https://github.com/Fourdee/DietPi/issues

Hey MichaIng,

thx for your reply.

Maybe I found the error:
I did another fresh installation without installing any additional sw. Just (as before) changed the RootFS to an internal SSD with the drive manager.
As you can see in the attached pic the ssd resizing was not successfully cause of the EOD, truncated line.


Is there any possibility to solve that problem?

Thx

Upate: A few more infos:

fdisk -l /dev/sda

Disk /dev/sda: 29.8 GiB, 32017039360 bytes, 62533280 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0xe7a360db

Device     Boot Start      End  Sectors  Size Id Type
/dev/sda1        2048 62531583 62529536 29.8G 83 Linux

Please try the following:

wget https://raw.githubusercontent.com/Fourdee/DietPi/testing/rootfs/etc/systemd/system/dietpi-fs_partition_resize.service -O /etc/systemd/system/dietpi-fs_partition_resize.service
wget https://raw.githubusercontent.com/Fourdee/DietPi/testing/rootfs/var/lib/dietpi/services/fs_partition_resize.sh -O /var/lib/dietpi/services/fs_partition_resize.sh
systemctl daemon-reload
systemctl enable dietpi-fs_partition_resize
reboot

There was an issue with this script for /dev/sdX root file systems. Hope the new version solves it.

Thx for ur reply.

After executing your lines, the error line has disappeared, but the system hangs on initializing the eth-connection.

Could a fresh installation help? With your testing lines before I try to change the RootFS?

Could be worth a try.

But at first try to reset network settings via dietpi-config, switch eth from dhcp to static e.g. and the other way round.

But not sure which other steps might have gone wrong with full rootfs, thus if it does not work, fresh install, until every first run setup step is done, including dietpi-software initial run and dietpi-update. Then do just the two wget commands to update the resize service and script, then move rootfs to external drive, which will trigger the other commands as well.

Unfortunatly the same result.

Even when I wget the two scripts before I change the RootFS, the error appears.

Also when I switch between Static and DHCP.

Maybe there is a bigger problem?

thx for ur help again.

Still the same problem after a reboot: the xu4 hangs and I have to do a ctr-alt-del to force it into a second booting.

Any more ideas on that?

thx a lot.

Hey there,

I send you today a bug report via the dietpi-bugreport at 15:48 Berlin-Time .

Maybe there is some more infromation that is needed.

Greets and a big thx!

Dunno if that is still a problem, but concerning the eth0 connection I had the a similar fault in v15x of Diatpi on a XU4.
Solution was:

LAN not found:
	Check if boot/exynos5422-odroidxu4.dtb exists
	If yes, open DietPi/boot.ini and look for fatload mmc 0:1 0x44000000 exynos5422-odroidxu3.dtb
	and change the line fatload mmc 0:1 0x44000000 exynos5422-odroidxu3.dtb
	into fatload mmc 0:1 0x44000000 exynos5422-odroidxu4.dtb
	Reboot

You could alter the boot.ini on your pc pluging the sdcard into a reader and using something like notepad+

Greetz