Odroid C4

Hi,

are there any plans for an C4 image?

TY,

Andy

Hi,

many thanks for your request. As long as there is no image available for the C4, you might try to install latest Armbian image and run DietPi install script afterwards :slight_smile:

https://dl.armbian.com/odroidc4/Buster_current

https://github.com/MichaIng/DietPi/issues/1285

Hi,

thanks for the fast response. I’m still waiting for my first C4 board. I let you know the results ASAP.

Let me know when it’s arriving (or you have an arrival date) and I’ll create an “official” testing image.
At best write to this issue: https://github.com/MichaIng/DietPi/issues/3500
Due to lack of time I’m not too regularly check the forum, currently :frowning:.
As you can see, initial support has been added to the code, so the testing image will be based on current dev code to test correct detection and stuff like Kodi as intended :slight_smile:.

Hi

I’ll keep an eye on this thread, because I’d like to try DietPi on a C4, with the view to using that as my default platform. (Moving from the excellent C2)

If I can do anything to help, please let me know.

FYI, I have the following hardware that I can test on the devices.

ODroid 7 inch touch screen & speakers
ODroid 3.5 inch touch screen
ODroid RTC
Various USB sound cards
USB LAN dongles (dual LAN is quite important to the lighting setups I deploy)


Best wishes,

Stuart

Another C4 owner here. Have the board in hand. Would love to try out a test image. I feel like this board has loads of potential and I can see Diet Pi helping it spread it’s wings.

Hi

Mine should arrive in the middle of the week…


As Micheal says above, keep an eye on this GitHub thread…

https://github.com/MichaIng/DietPi/issues/3500

Regards,

Stuart

Hey guys,

first image up: https://github.com/MichaIng/DietPi/issues/3500#issuecomment-636504218
Bear with me if it’s not booting, since I cannot test on real real device, but checked that all kernel/dtb/bootloader files are in place and reflashed uboot to the image file as well. I’ll repack in case :wink:.

Not sure why it has become 1 GiB, used drive space is ~500 MiB, I’ll try to close the wholes and further shrink it on next repack :roll_eyes:.

It’s current v6.31 development state, however no breaking changes so far, more fixes. Kodi support has already been implemented, WireGuard will follow, let me know if you’re missing other software title support, I did not yet went through all of them.

Also it can be overclocked, check /boot/boot.ini, this will be added to dietpi-config > Performance Options. If you find other useful settings/better defaults for boot.ini, let us know.

Note that this is quite early development stage as well according to kernel and software packages by Meverics repo, if you face any issues with those packages, e.g. during APT installs/upgrades (I ran into one when upgrading the kernel…) let us know, we’ll check whether it’s from us, else forward to Meveric.

Enjoy :slight_smile:!

Thanks, as soon as my C4 arrives I’ll give this a try.

Do you want to create a check list for any of us to run through?

Good idea. Most important indeed the obvious:

  1. Boot
  2. First boot setup finishes without errors until login prompt
  3. First run update update is skipped due to version already current, dietpi-software run should be fine
  4. WiFi via dietpi-config > Network Options: Adapters
  5. Onboard audio via dietpi-config > Audio Options

Then more optional, depending on what one is interested in or what peripherals/cooling etc is available:
6. If one has a serial terminal, would be good to know which serial device is available for interactive console by default. /dev/ttyS0 seems to be the debug console, but not sure if systemctl enable --now serial-getty@ttyS0 works fine as well or another device is the better default.
7. Testing the down/overclocking options in /boot/boot.ini, especially if the highest pre-defined frequency is stable and if intermediate ones work as well. We could then add these to dietpi-config > Performance Options.
8. Kodi: dietpi-software install 31
9. dietpi-config > Tools > Benchmarks, and uploading them via dietpi-config would be awesome, so we can get some idea how fast it is compared to other SBCs :slight_smile:.

I’ll give this a whirl in about an hour or so. :sunglasses:

Just tested it. No boot. No video output and no blue LED (blue LED indicates it’s booting properly)

Damn, just for completeness and testing, here is the base image I used: https://oph.mdrjr.net/meveric/images/Buster/Debian-Buster64-1.0~RC1-20200505-C4.img.xz

I’ll recheck that bootloader, kernel and dtb is installed and placed correctly.

I can confirm, the github image is not booting. Neither with sd card nor with eMMC. The original C4 ubuntu mate image ist working as well as the RC1 buster image.

Just a side note. Ubuntu is not Debian. At least a working base image from Meveric would be needed. Otherwise DietPi will not work on top of it.

Sure. I mentioned ubuntu for information only.

I’ve tried the DietPi installer on the latest armbian buster server. The script ran into a problem (mount -o remount /tmp). It fails due to two identical lines (tmpfs /tmp tmpfs size=1877M,noatime,lazytime,nodev,nosuid,mode=1777
) in the fstab. After I commented out the lines the script finished without further errors.

After a reboot I recognized some warnings and commented out one of the same, duplicate lines in the fstab.

On the first sight, everything looks fine, now. Can you recommend to proceed with this image or should I wait for the first “official” release? BTW, it will be a docker box for iobrocker and a mariaDB instance.

Is it too much to ask of the C4 to run ESPhome, Octoprint, and PieHole? Would be nice to consolidate some of my SBC’s to just one running the three main things I want.

jayjr1105
Once there is a working image, it should be possible to consolidate your applications.

The C4 does not bring up ethernet after a soft reboot. It requires a power cycle. Looks like a kernal issue?!

[    5.350862] meson8b-dwmac ff3f0000.ethernet: Failed to reset the dma
[    5.350888] meson8b-dwmac ff3f0000.ethernet eth0: stmmac_hw_setup: DMA engine initialization failed
[    5.350908] meson8b-dwmac ff3f0000.ethernet eth0: stmmac_open: Hw setup failed

Intermediate status: I decided to proceed with the armbian based image. Because a dying SSD I need to move the data from the old C2 based docker host to the new one asap. Except the soft boot bug I’m not aware of any other issues. Once there is a stable dietpi image available it’s not a big deal to reinstall the OS on a docker host.

If you need any information from my image please don’t hesitate to ask. :slight_smile: