Odroid C2 overclocking (Solved)

Over time I’ve discovered that only the changes made in the /DietPi/boot.ini or other file depending on which machine we are speaking of work. Changes to the file made in /boot/. aren’t stored and this has worked for me on several machines up until now. I’ve tried making changes to the boot file in both directories on the Odroid C2 and regardless of which file I change they are never perminant. What I’m trying to do is mildley overclocking the machine since it runs boinc/seti@home and every clock cycle counts. I have read it’s safe to take this board to 1656 mhz but it just won’t stick, after I reboot the file is overwritten… What am I missinfg here?

Here’s what it should look like

max cpu frequency in dvfs table / in MHz unit

setenv max_freq “2016” # 2.016GHz

setenv max_freq “1944” # 1.944GHz

setenv max_freq “1920” # 1.920GHz

setenv max_freq “1896” # 1.896GHz

setenv max_freq “1752” # 1.752GHz

setenv max_freq “1680” # 1.680GHz

setenv max_freq “1656” # 1.656GHz

setenv max_freq “1536” # 1.536GHz

Boot Arguments

add max_freq in bootargs

setenv bootargs “root=UUID=e139ce78-9841-40fe-8823-96a304a09859 rootwait ro ${condev} no_console_suspend max_freq=${max_freq} hdmimode=${m} ${comde} m_bpp=${m_bpp} vout=${vout} fsck.repair=yes net.ifnames=0 elevator=noop disablehpd=${hpd}”

I made the changes in both versions of the boot.ini file and double chacked to be sure they were character for character the same and I can now clock to 1656 mhz. Oddly enough I’m a little let down because I was expecting unicorns and rainbows :wink:


did you checked the Performance Options within dietpi-config tool? depending on your device, there are various options available

Overclocking isn’t available on any of the Odroids from what I’ve seen. Would be nice if it were though :slight_smile:

I guess you know why options are not available :sunglasses: