Odroid C2: Kernel hangs after update to v119

Hey there,

as mentioned in https://github.com/Fourdee/DietPi/issues/366 (and marked there as solved) hangs the kernel after updating to v119.

I come from v117, doing a dietpi-update and after rebooting the kernel hangs, no console available.

I tried it several times with my backup-version of my installation. 1. dietpi-update, then apt-get update&upgrade 2. vice versa.
Some outcome.

How can I fix this?
Any help would be great. Thx a lot.

BTW: I use an unmodified boot.ini.

Greets, mike175de

Hi Mike,

Yep, as you can see in the git ticket, had a few issues with getting the latest kernel installed, without removing itself. I did test as many possible scenarios for the update, but clearly I missed one.

Whats the kernel version of your backup, prior to updating kernel?

uname -a

And, after running the update. Plug the SD/EMMC into another machine and provide me with the file list for /boot:

ls -lha /boot/

. Screenshot if its easier, but I’ll need to see the full filenames.

Hey Fourdee,

thx for the fast reply. :smiley:

I can’t say what was different then the other times, but after doing a dietpi-update and a reboot the system is up and running. No kernel-hanging anymore. :question:

Maybe this are useful informations for you:

before the update:

uname -r 
3.14.29+

after the update:

uname -r 
3.14.65+

after the update:

ls -lha /boot/ 
insgesamt 69M
drwxr-xr-x  3 root root  16K Jan  1  1970 .
drwxr-xr-x 21 root root 4,0K Mai  2 22:22 ..
-rwxr-xr-x  1 root root 1,9K Jun  2 18:35 boot.ini
-rwxr-xr-x  1 root root 108K Mai 19 15:43 config-3.14.29+
-rwxr-xr-x  1 root root 108K Mai 27 15:25 config-3.14.65+
-rwxr-xr-x  1 root root 2,0K Jun  2 18:35 config.txt
drwxr-xr-x  5 root root 4,0K Jun  2 18:35 dietpi
-rwxr-xr-x  1 root root  11K Jun  2 18:35 dietpi.txt
-rwxr-xr-x  1 root root  13M Jun  2 18:34 Image
-rwxr-xr-x  1 root root 5,5M Jun  2 18:32 initrd.img-3.14.29+
-rwxr-xr-x  1 root root 5,5M Jun  2 18:34 initrd.img-3.14.65+
-rwxr-xr-x  1 root root  29K Mai 27 16:14 meson64_odroidc2.dtb
-rwxr-xr-x  1 root root 2,7M Mai 19 16:29 System.map-3.14.29+
-rwxr-xr-x  1 root root 2,8M Mai 27 16:11 System.map-3.14.65+
-rwxr-xr-x  1 root root 5,5M Jun  2 18:34 uInitrd
-rwxr-xr-x  1 root root 5,5M Jun  2 18:34 uInitrd-3.14.29+
-rwxr-xr-x  1 root root 5,5M Jun  2 18:34 uInitrd-3.14.65+
-rwxr-xr-x  1 root root  12M Mai 19 16:29 vmlinuz-3.14.29+
-rwxr-xr-x  1 root root  13M Mai 27 16:11 vmlinuz-3.14.65+

Greets, mike

Thanks Mike,

Everything looks in order. Very bizarre its now working, but good to hear. If you get any further issues, please let me know.

If this can be useful to somebody, I have installed v119, not update, but fresh install, on my Odroid C2, and everything has worked like a charm.