ODROIC C1+ gpu install error ?

I tried reinstall my odroid DietPi to latest versien from 0.

Ticked Kodi, FTP, Transmission to install.
i get this error and cant pass by. please help


Hi Marg,

Thanks for the report.
I’ll run some tests on my C1 today and see if we can replicate. Will get back to you later today.

Thank You mate. If u cant fix it today - with new ver. Could You provide some older ( working ) i need my kodi tonight :frowning:

Hi Marg,

Replicated, looks like you found a bug :slight_smile:. You can track progress here: https://github.com/Fourdee/DietPi/issues/617. Will let you know when its resolved.

I’d rather it not be found…

I can add - when i updated earlier from some old ver. DietPi using dietpi update system. Kodi was working normally
(There was only some errors with FTP - lost permissions to delete files etc… ( after update))

That why i wanted to do fresh install…

I don’t know if its connected but , when i tried to go forward withouth Kodi…
i get these :frowning:

Hi Marg,

Unfortunately, it appears the issue is with the libump-odroid and mali450-odroid packages. This is outside DietPi’s hands at the moment as the packages appear to be “broken”, they are maintained by Meveric.

I’ll send Meveric a message and get back to you when he replies: http://forum.odroid.com/viewtopic.php?f=114&t=17569&p=169386#p169386

Ok, Thanks for support.

Can i find somewhere some older versions, as temporary solution ? Before update it was working flawleslly.

I don’t believe old packages are available from Meveric’s repo, however, you’d need to check with him.

Meveric has fixed the packages, please do the following to clear the existing ones:

apt-get purge aml-libs-odroid libump-odroid mali450-odroid xf86-video-mali-odroid

Then you can run dietpi-software and select Kodi for installation.

Let me know how it goes.

Thank You very much Daniel.
Working again flawlessly… for now :slight_smile:

When will appear some problem/bugs will msg.

<33 DietPi

Great to hear.

All credit to Meveric on this one, he maintains those packages.