NoIp cannot update hostname

Hi everyone,
thanks for the awesome job you guys are doing mantaining the DietPi project. It works smoothly on a RPi3 and
I couldn’t have asked for better. I would love to contribute if only I was good at programming.
Anyways, the problem is pretty simple: after the latest update (6.:sunglasses:, NoIp installs and configures without issues, and also shows as “Online/Enabled”. However, I can’t get it to update the hostname. I’ve tried building directly from NoIp’s website, with the same result.
I also tried opening the 8245 tcp port but nope. The software worked fine before update. I thought maybe it was the low update interval (5 minutes) but I also tried changing that. The logs don’t show anything significant, as you can see:

May 18 22:32:39 DietPi systemd[1]: Starting noip2...
May 18 22:32:39 DietPi systemd[1]: Started noip2.
May 18 22:32:39 DietPi noip2[15921]: v2.1.9 daemon started with NAT enabled
May 18 22:32:40 DietPi noip2[15921]: **myddns** was already set to **myip**

If you got any ideas/need further logs hit me up! luv you