Nextcloud v25 DISABLED for armv7l (I have Raspberry Pi 2 B). How to revert to v24 32bits?

Creating a bug report/issue

Required Information

  • DietPi version | G_DIETPI_VERSION_CORE=8

  • Distro version | bullseye 1

  • Kernel version | Linux DietPi 5.15.76-v7+ #1597 SMP Fri Nov 4 12:13:17 GMT 2022 armv7l GNU/Linux

  • SBC model | RPi 2 Model B (armv7l)

Additional Information (if applicable)

  • Software title | Nextcloud
  • Was updated web interface from 24 to 25

Steps to reproduce

  1. Installed LLMP + Nextcloud last month from fresh DietPi
  2. Today I accepted the proposed upgrade from 24 to 25 within web interface, and after that everythin went downhill…
  3. Unsuccessful backup restore
  4. Uninstalled LLMP + Nextcloud from dietpi-software
  5. Unsuccessful uninstall of mariadb
  6. Tried for hours to fix it and finally got dietpi-services ok
[  OK  ] DietPi-Services | mariadb		 active (running) since Fri 2022-11-18 23:26:26 WET; 38min ago
[  OK  ] DietPi-Services | php7.4-fpm		 active (running) since Fri 2022-11-18 23:26:26 WET; 38min ago
[  OK  ] DietPi-Services | lighttpd		 active (running) since Fri 2022-11-18 23:26:28 WET; 38min ago
[  OK  ] DietPi-Services | cron			 active (running) since Fri 2022-11-18 23:26:28 WET; 38min ago
[  OK  ] DietPi-Services | dropbear		 active (running) since Fri 2022-11-18 23:19:24 WET; 45min ago
[ INFO ] DietPi-Services | dietpi-vpn		 inactive (dead)
[ INFO ] DietPi-Services | dietpi-cloudshell	 inactive (dead)
[  OK  ] DietPi-Services | dietpi-ramlog	 active (exited) since Fri 2022-11-18 23:19:24 WET; 45min ago
[  OK  ] DietPi-Services | dietpi-preboot	 active (exited) since Fri 2022-11-18 23:19:24 WET; 45min ago
[  OK  ] DietPi-Services | dietpi-postboot	 active (exited) since Fri 2022-11-18 23:19:30 WET; 45min ago
[ INFO ] DietPi-Services | dietpi-wifi-monitor	 inactive (dead)
  1. Tried to install Nextcloud from scratch with dietpi-software install 114

Actual behaviour

  • ID 114 | =0 | Nextcloud: File sync, sharing and collaboration platform | +MariaDB +PHP +Redis +webserver **DISABLED for armv7l**

Extra details

How can I install Nextcloud v24 from dietpi-software again?

Many thanks in advance

P.S: This is my 1st post so I apologise in advance for anything done wrong

run this from command line to get nextcloud 25 working on 32bit systems.

sed -i 's/self::SIZE_PROPERTYNAME, function () use ($node): ?int/self::SIZE_PROPERTYNAME, function () use ($node)/' /var/www/nextcloud/apps/dav/lib/Connector/Sabre/FilesPlugin.php

There are workarounds available, see


1 Like

can’t read /var/www/nextcloud/apps/dav/lib/Connector/Sabre/FilesPlugin.php: No such file or directory

None works

I’m trying to install from scratch and Nextcould does not appear on the software list no more (only Nextcloud Talk appears)

Actually NC is disabled due to a bug in NC 25. But it will be enabled again this weekend on next release Dietpi v8.11 as we have implemented a workaround for the NC issue

NC 25.0.2 will fix this issue from NC side.

Anyway, NC 25 will be last available version on 32bit systems as NC will drop support for it.

1 Like

Ok you deleted nextcloud already? This command would only work if nextcloud is still in installed.
I guess you have to wait for the next dietpi release or you switch to the ARMv8 image, if you have the v1.2 model of the RPi 2b.

Edit: corrected version of rpi 2b to work with 64bit

Next release is planned for the weekend. Most probably today evening.

1 Like

The v1.2 PCB model is required for 64-bit support. The v1.1 one uses an ARMv7 SoC: Raspberry Pi - Wikipedia

Yes I did, I had to, it was the only way I could then fix mariadb error (don’t ask me why)

Here’s a pic of my PCB, I think PCB is 1.1 correct?

Will it be possible for me to upgrade my current DietPi installation, or will I need to do a fresh microSD install?

We could have tried to work around issues on MariaDB :wink:


Of course you can update to DietPi 8.11 once released. But you will stay on 32bit.

If it is time critical, you could switch to our Dev branch to get early bird access :wink:

1 Like

Indeed we could have…but I’ve read all other posts here with similar mariadb problems and nothing worked for me, so I though why bother the guys asking for help when I can just perhaps reinstall NextCloud? Turns out I did managed to fix mariadb but then when I tried to reinstall NextCloud it just wasn’t on the list anymore :smile:

Great! No worries, I’ll wait for the update then. With my 1.1 board I’ll always stay on 32bit correct? 'Cause my Raspberry Pi’s CPU is 32bit, right?

fully correct. No way to run 64bit on a RPi2 1.1

1 Like

So I’ve updated to v8.11.2 but NextCloud still does not appear in software list… What do you recommend I should do?
Try to download v24 and manually install it?
Captura de ecrã_2022-11-20_22-15-27

Error message on command line install still the same as before

Ok this would be our fault. Need to check with our developer.

A live patch might become available tomorrow.

1 Like

Live patch is up. Run dietpi-update to apply it.