Nextcloud install / operation fails on Pine64, Dietpi 6.24

Hello All,

I am running Dietpi on a Pine64.

I only intend to use this with Nextcloud.

This setup worked for about 6 months, but my SDcard went bad. I got another SDCard, got a new dietpi image, installed it to the SDcard, upgraded it, then installed Nextcloud #114.

The installation is not smooth as it has permission issues with /var/log/redis, that got fixed with:
chown -R redis:redis /var/log/redis

After that, dietpi-software says that it is installed, yet it does not appear to be running, and there is no web interface to it.

Can anyone give me some ideas where to look / test?


chown -R redis:redis /var/log/redis

Do you run a Jessie image?? I found a similar on issue on Jessie, where the APT package install does not include /run/redis and /var/lib/redis permissions, thus the APT install is doomed to fail with the included service start step… I fixed that for Jessie in our install code to pre-create the dirs with correct permissions.

If that now also occurs on Stretch (although I just some hours ago did a successful test install), then we need to raise a bug report to the Debian bug tracker…

After fixing it manually, did you re-run the install via dietpi-software install 114?
Which webserver do you use? Default Lighttpd?

Steps to check:

journalctl -u mariadb
journalctl -u php7.3-fpm
journalctl -u redis-server
journalctl -u lighttpd

Sorry, how do I check if I am running Jessie or not?

I’m using:

Then updating with dietpi-update

I get errors on journalctl -u lighttpd

says there is no folder or filename for


it looks like it starts, tries to update that error log that isnt there, then restarts about 5 times, then fails.

If I manually make (as root) the /var/log/lighttpd folder, the error is now that the error.log file can’t be created /modified because of permission issues. who should own that folder, what should the chown -R command be to properly set the permissions?

FYI: Apparently my board is a Rock64, not a Pine64.

To check distro: echo $G_DISTRO_NAME

To fix Lighttpd then try to pre-create that dir+file with correct permissions:

systemctl stop lighttpd
mkdir -p /var/log/lighttpd
> /var/log/lighttpd/error.log
chown -R www-data:www-data /var/log/lighttpd
systemctl start lighttpd


I was using STRETCH.

It looks like you solved my problems by pre-creating the /var/log/lighttpd folder and setting its owner to www-data

It appears to be running ok.


Also, I could not do a regular diepi-software install 114, it had to be a re-install.

Great that it works now :smiley:.

However strange that /var/log/redis as well as /var/log/lighttpd was missing or wrong permissions. Perhaps RAMlog somehow failed. Would fit to the fact that the initial install worked through.

If you face something similar, then at least it could be checked via:

journalctl -u dietpi-ramlog
cat /var/tmp/dietpi/logs/dietpi-ramlog.log