nextcloud doesn't install apache automatically


Last night, I copied the DietPi img to my SD card and booted it for the first time. I selected nextcloud to install, let it complete rebooted, tried to login to http://myip and http://myip/nextcloud but got nothing, then I went back and installed apache separately and now I am able to access the nextcloud interface through the browser. After docu i’ve seen along the way, I was the imperssion that apache should be installed automacically as dependency along with nextcloud…?
I’m not so sure if that’s changed recently-ish…? If so, no bug report necessary, otherwise, how do I file a bug?

Hmm, when installing Nextcloud, a webserver should be installed automatically, if none has been marked as installed already. By default this is not Apache but Lighttpd. When dietpi-software opens, there is the “Webserver preference” menu entry which allows to decide which webserver should be installed automatically with any software that requires it, including Nextcloud.

Just to be sure you do not have two webservers now: dpkg -l lighttpd
Probably Lighttpd for some reason failed to start.

Yes, lighthttpd is now installed, and apache isn’t:

root@DietPi:~# dpkg -l lighttpd
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name           Version      Architecture Description
ii  lighttpd       1.4.53-4     armhf        fast webserver with minimal memory footprint

I haven’t gone back and retried this to see what exactllt happened. It might be, that httpd just failed to start, I’m not sure at this point.

Okay so with Lighttpd the default webserver is installed as suggested. If Nextcloud is still not reachable please paste:

journalctl -u lighttpd

Okay, I just re-ran the installation sequence from square one and this time it installed and came up just fine…who knows what happened before…?