NEXTCLOUD APP : "unable to connect for the moment"

Hi everyone,

Nextcloud is setup as new on my RaspberryPi. I can setup my Nextcloud account from my computer at home no problem. I can access my Nextcloud account from outside of my home network no problem either by my IP address or by my NoIP hostname. For example using Safari browser on my iPhone in LTE/3G. It works great.


When come the time to use the Nextcloud App on the iPhone it’s not working at all. I add a server in the app “” (which works perfectly when I connect to it using the web browser on the same phone), enter my nextcloud user name, password and every time I touch “connect” then it display an error message “can’t connect for the moment”.

When I use the Nextcloud Application on my Mac at home with the same credentials… it works perfectly.

So I am suspecting the mobile app of Nextcloud may try to connect to a different port than “80”. I had to forward port 80 on my router settings. I think I may need to forward the port the mobile app may try to use. What do you think ?? Any idea of which port the Nextcloud App may require ? Or any idea on how to resolve this error in case I am wrong assuming it’s just a port question ?

Thanks a lot

Nextcloud and Owncloud recommend to use https:// - for which 443 is the default port.
They do work on port 80 but maybe this is worth looking at?

Thanks Johnvick. Yes I would love to be able to setup HTTPS on my server… the problem I have with that is NoIP apparently do not support Certbot/Let’sEncrypt :face_with_raised_eyebrow:
I checked on their website (I have an “enhanced” account with them for the moment) and they would only provide ssl certificate with their own solution of certificate which cost mucho dinero and require a superior type of account. So I am a little bit stuck here willing to go ssl but not seing how it would be possible.

EDIT : from the certbot page on dietpi it reads “A URL/domain (eg: NoIp is recommended for a URL/domain that points to your device. Free NoIp accounts do not work with Letsencrypt, you must own a domain name and use NoIp Premium features”.
If I do the math correctly, from the NoIP page I can see a domain name registration is 29.95$, a Geotrust QuickSSL Premium is 129.99$. Which would give a total of around 160$ per year. It’s expensive. Are my math correct ? Would it be the right way to go ssl with DietPi ?

Can’t help beyond this as I use dyndns - there is a cost attached to this of course. I use a self-signed cert and it works OK.

So I checked with Nextcloud support. It seems on their forum a bunch of people are having the same issue with the iOS app. Anyway… I created a “test” account on my Nextcloud for support to check and that was the answer I got from them :

"This is the response at connection :

<NSHTTPURLResponse: 0x60800042d3e0> { URL: } { status code: 405, headers {
Connection = “keep-alive”;
“Content-Length” = 181;
“Content-Type” = “text/html”;
Date = “Sun, 04 Dec 2016 18:56:29 GMT”;
Server = “nginx/1.4.6 (Ubuntu)”;
Unexpected response (405 Method Not Allowed).

And I have no idea what to do with that :smiley: looool
Is that good ? Bad ? the “method not allowed” does it prove “http” is not supported by the app and it’s mandatory to use https ?

LetsEncrypt (certbot) provides and sets up free SSL certs. The only downside is you may get one of those “untrusted SSL” messages when connecting to the https page.

I can see a domain name registration is 29.95$,

Yep, so the Plus managed DNS package is what you need + Domain name:

405 error

Not sure, do you get the same error when trying to access the webpage from any device on your local network (eg: PC/Ipad etc)?

After you receive this error, take a look at the log file for Lighttpd, maybe it can provide us with more information:

cat /var/log/lighttpd/error.log

NextCloud installation is working fine my end, my suggestion would be to test a basic install:

  • Write a fresh DietPi image
  • Install only NextCloud and test

Failing that, test with another webserver:

  • Write a fresh DietPi image
  • Select Apache2 as webserver choice
  • Install only Nextcloud and test

The other option would be to try Pydio. Similar to NextCloud in terms of features.

Not sure, do you get the same error when trying to access the webpage from any device on your local network (eg: PC/Ipad etc)?

I don’t get any error when accessing from a webpage from any device (iPhone included) in and outside my network : it works perfectly. The error is only when trying to connect using the iOS app. As someone said before it may be because Nextcloud app wants to use https ? I am looking into having SSL anyway (btw many thanks for your answer regarding that on an other topic)… so once it will be done I will try again in HTTPS and we will see if it makes any difference.

Appreciate the advice to go for Pydio. It seems to be very very good. But it does not integrate Calendars sync nor Contacts sync. Which means then I would have to add Baikal for Caldav and Cardav. It’s a solution. I may end up doing that. It’s just if I could do all of that with 1 software (Nextcloud) I would prefer. Not particularly interested in Owncloud, I know it’s the same as Nextcloud but I prefer the way Nextcloud are open source etc…

Btw… when I type that inside my ssh connected to the Pi having Nextcloud on it : “cat /var/log/lighttpd/error.log” then nothing happen, it just goes to a new line with cursor ready to take new input command.

DietPi-Ramlog clears log file on a hourly basis (to free up memory), so you need to create the error on your iPhone IOS app, then check the log file afterwards. Either way, if the log file doesnt show any errors, then we may need to increase log verbose level, but i’ll check that over our remote session.