New update (7.4.2) no video output (RPi4)

Hello,

I updated yesterday but there was no video output on my TV via HDMI. It did trigger 680x480 resolution and then 1080p resolution on my TV but stays black the whole time. No issues on SSH. Normally I see console text before Kodi. Did a restore to the backup before update and it all went back to normal.
8gb RPi4 - video working on 7.3.2 but not 7.4.2

Cheers,
Gabba

Hi,

Do you have a backup and are able to go back to 7.3?

Hi Joulinar, yep, restored 7.3.2 straight after and it’s working fine again.

for testing, can you do apt update && apt upgrade and reboot the system afterwards.

pls keep your 7.3.2 backup ready :wink:

Tried that but no luck, back to black screen and then had to restore backup which worked again. Strange

it’s not strange. It only prove that one of the apt packaged you updated is causing the screen to go black and not a DietPi version.

Can you share following on the version working

apt update && apt list --upgradable

This should display all available apt packaged ready to be updated.

Fair enough! Thanks for your help resolving, this is the output on the working version:

apt update && apt list --upgradable
0% [Working]
Get:1 http://raspbian.raspberrypi.org/raspbian buster InRelease [15.0 kB]
Hit:2 https://apt.sonarr.tv/debian buster InRelease
Hit:3 https://download.mono-project.com/repo/debian raspbianbuster InRelease
Get:4 https://archive.raspberrypi.org/debian buster InRelease [32.6 kB]
Get:5 http://raspbian.raspberrypi.org/raspbian buster/main armhf Packages [13.0                                                                                         MB]
Get:6 https://archive.raspberrypi.org/debian buster/main armhf Packages [378 kB]
Fetched 13.4 MB in 44s (305 kB/s)
Reading package lists... Done
Building dependency tree
Reading state information... Done
9 packages can be upgraded. Run 'apt list --upgradable' to see them.
Listing... Done
libgssapi-krb5-2/stable 1.17-3+deb10u2 armhf [upgradable from: 1.17-3+deb10u1]
libk5crypto3/stable 1.17-3+deb10u2 armhf [upgradable from: 1.17-3+deb10u1]
libkrb5-3/stable 1.17-3+deb10u2 armhf [upgradable from: 1.17-3+deb10u1]
libkrb5support0/stable 1.17-3+deb10u2 armhf [upgradable from: 1.17-3+deb10u1]
libraspberrypi-bin/testing 1:1.20210805-1 armhf [upgradable from: 1:1.20210527-1]
libraspberrypi0/testing 1:1.20210805-1 armhf [upgradable from: 1:1.20210527-1]
libsndfile1/stable 1.0.28-6+deb10u1 armhf [upgradable from: 1.0.28-6]
raspberrypi-bootloader/testing 1:1.20210805-1 armhf [upgradable from: 1:1.20210527-1]
raspberrypi-kernel/testing 1:1.20210805-1 armhf [upgradable from: 1:1.20210527-1]

Ok thx. Can you share your current kernel version

uname -a

There has been a new kernel package upgrade in the meantime (after you ran into the issue), which fixed HDMI CEC support at least. Probably the faulty version also caused your issue and was fixed as well in the meantime.

To just narrow it down, upgrade the other packages first, reboot and assure that everything is still working:

apt install libgssapi-krb5-2 libk5crypto3 libkrb5-3 libkrb5support0 libsndfile1

Probably update your dietpi-backup 1.

Then upgrade the kernel/firmware package stack (everything else):

apt upgrade

Linux DietPi 5.10.17-v7l+ #1421 SMP Thu May 27 14:00:13 BST 2021 armv7l GNU/Linux

Still had video after apt install libgssapi-krb5-2 libk5crypto3 libkrb5-3 libkrb5support0 libsndfile1


Then also after apt upgrade.

All fixed after the dietpi-update as well!

Thanks so much to both of you for your help!

Most probably your issue has been fixed with latest Raspberry OS kernel update.