New install stuck at random: nonblocking pool is initialize


I’ve written the latest DietPi image to an sd card (8Gb Sandisk), put it into the PI and powered the PI.

After two reboots, the console output gets to “random: nonblocking pool is initialize” then the green led lights up a few more times then eventually stops, the boot process goes no further.

I’ve tried this now with two sd cards and two pi’s with the exact same results.

Image I’m using is DietPi_v81_RPi, I’m writing the image with win32diskimager on windows 8.1

Any help with getting this booting would be great.


Hi Adrian,

If you could answer the following questions, i’d be grateful:

  • Can you give me the stats of your power supply (eg: Amperage/brand)
  • If you have another PSU, have you tried another power supply?
  • Has this error occurred when using the official Raspbian?
  • What are the models of your RPi’s (eg: Model B+ 512mb)?
  • Your Sandisk 8gb cards, are they “Ultra”?

You said after two reboots, could you please:

  • Write a new DietPi image, power on etc
  • When the error occurs, power off the device.
  • Plug your SD card into your PC
  • Open up the boot partition (eg: my computer > USB drive)
  • Create a .Zip file containing all the files and folders.
  • Email or attach the .Zip file.

Thanks Adrian.


I have a few power supplies, one is 5v 2a and the other is 5v 2.5a both are stontronics
This error hasn’t occurred with standard raspbian, we have over 90 raspberry pis
All the pis are Model B+ v1.2
Sd cards are Sandisk 8Gb SDHC I , hardware id : SanDisk_SD6SB1M128G1022IX

This is a link to the zip;


Thanks Coxse, will take a look when I can.

Apologies for the delay.

I’ve checked your settings from the zip file. Everything seems in order.
I’am completely stumped with this one as the “random: nonblocking pool is initialize” error indicates some form power issue, ram and/or filesystem corruption.

Your issue is the 1st and only report i’ve had of this error. The only thing i can advise is to re-download the dietpi image and try again.