Networking problem

This is a Pi2 running dietpi 126. This was working yesterday, today it isn’t - all I did was install the packages necessary to connect to an NFS share on another device on the LAN - maybe not relevant.

I have wired LAN configured as and wifi as - both static - and yesterday both worked independently.

Now I cannot connect by SSH or PiCam web interface unless I have a LAN cable plugged in. As soon as I plug one in I can connect - but using WinSCP on the wifi IP ( and then opening PuTTy it reports I am connected to

I run dietpi-config, go to networking all looks as it should on both interfaces. If I then restart the wifi interface and unplug the LAN cable I am connected by wifi and connecting with WinSCP/PuTTY gives the correct IP.

If I reboot with the LAN cable in I can disconnect this after it boots and then wifi works as it should.

This is the same with two wifi adaptors that are not the same model.

Sorry if this is confusing - the short version is that I cannot get wifi working unless I boot with a cable in and then remove it.

Any tips on how to troubleshoot this?

Turned out to be (I think) an IP address conflict - I thought I had eliminated this by rebooting the router a couple of times, but after removing a couple of redundant fixed IP addresses on the router it all came right.

Hi John,

Great to hear its resolved. IP conflicts are easily done, you should see my router address reservation table (50+ entries) lol.