Netdata, on fresh install, not working.. ( RockPro64)

DietPi-Software: G_AGI netdata
│ - Exit code: 100
│ - DietPi version: v6.25.3 (Fourdee/master) | HW_MODEL:42 | HW_ARCH:3 | DISTRO:4
│ - Image creator: DietPi Core Team
│ - Pre-image: ARMbian

│ Log file contents:
│ E: Package ‘netdata’ has no installation candidate

│ Unable to continue, DietPi-Software will now terminate.

Many thanks for your report.

Indeed Debian has removed netdata from the stretch-backports repository for some reason, see:
As long as the Buster packages do not work, we have to use the older 1.11 packages we compiled and stored on our server, for now. Official pre-compiled packages are sadly only available for x86_64 systems.

Another possibility is to use the official installer, which compiles the packages right away:
But this includes the install of dev/build packages and take more time, however should not take too long on RockPro64. We’ll test and find the best solution and implement with v6.26.

Tried of the latest beta and although there are no installation errors this time, it still won’t work for me …

Is it the same on your end?

Did you try it with v6.26 final? If it does not work, could you provide some error logs, e.g. journalctl -u netdata or not sure about log files in /var/log/netdata?

Worked for me with the installationscript “bash <(curl -Ss”.

First uninstall netdata from dietpi before starting the script.

Greetings :wink:

I couldn’t get Netdata to work on my rasp pi 4. But using that Bash/Curl script it works perfectly. Thank You Very Much!


what image you are using. 32bit or 64bit?
What version of DietPi you are running?

EDIT: I did a test installation on a RPi3B+ running 32bit image without issues.