Need to add mods-enabled links to cgid.conf, cgid.load to do cgi under Chromium(11)

Creating a bug report/issue

Required Information

  • DietPi version | 8.5
  • Distro version | bullseye
  • Kernel version | Linux DietPi 5.15.32-v7+ #1538 SMP Thu Mar 31 19:38:48 BST 2022 armv7l GNU/Linux
  • SBC model | RPi Zero 2 W
  • Power supply used | Apple charger brick
  • SD card used | Microcenter 16GB micro sd card

Additional Information (if applicable)

  • Software title | Chromium
  • Was the software title installed freshly or updated/migrated? fresh
  • Can this issue be replicated on a fresh installation of DietPi? haven’t tried yet
    ← If you sent a “dietpi-bugreport”, please paste the ID here →
  • Bug report ID | aa0416fd-424b-49f5-8603-bb602d9f3ffa

Steps to reproduce

  1. install apache, and chromium as the display
  2. install my own cgi software (an awk program and various data files)
  3. specify a url with my cgi app in it as the URL for Chromium to open
  4. won’t work until I enable those two modules in apache

Expected behaviour

  • Chromium should invoke my cgi program - which generates html - and chromium should display that generated page

Actual behaviour

  • fails

Extra details

I guess you have given the answer to yourself already. You need to activate the modules in Apache first.

I meant to request, but failed to actually do so - could those links be made automatically when Chromium is installed, so the system is ready for cgi?

there is no real relationship between the feature and Chromium, isn’t it? I mean you could try to access the same page from a different web browser on a different system/host. Or does it work from a different web browser client without the 2 modules being activated in Apache?

I’m trying to set up a self-contained kiosk where the site is served by apache and displayed by Chromium, both running locally on the dietpi machine, although I do sometimes use a remote browser to check how things look. Without these cgi mods being enabled, both the local and remote browsers fail with “Not Found. The requested URL was not found on this server.”

And there it become nearly impossible for us to know at which point we would need to activate these mods. Doing it for all just as default might be to oversized as it’s usually not needed by default users.

@MichaIng your thought?

I think you need to disable the fcgi-related modules first and uninstall php-fpm (+install php-cgi if not done yet) to avoid overhead, otherwise Apache sends PHP request to the FPM server.

There is no way to serve your program via FPM/fastcgi? Not that it would make much sense with a single client, but it would save you the PHP+Apache setup change.

My own application has nothing to do with php, or with FPM/fastcgi. A cgi program can be written in any language - I have my application written in awk, with another version written in python. You could write a cgi program in bash.