Mysql problem after apt-get update

This in on XU4 still on v 159. I did apt-get update and then installed update for mysql. After this Wordpress sites did not load.

I have had this problem before (more than once) but I can’t remember how I fixed it - it has something to do with userdata being in non-standared location, in my case /home/john.

I have restored from backup and all is working fine again but what is the reason for this?

Any help appreciated.

John

Hi John,

Hmm much changed since v6.0, but database location should be still in your userdata folder.

Are you using MySQL or MariaDB? In the first case I can’t say if the latest update might have changed some setting we expect or resets something with database location or root user authenticating.

For sure you need to check your error log: journalctl -t mysqld
Also check if the database location still points to the right folder:
ls -al /var/lib/mysql

And mysql_upgrade went fine after/during APT upgrade.

Hi Michael,

Thanks for your help - I tried again with same result, not a surprise. MySql was running OK, but the Wordpress sites weren’t. I couldn’t see a way to fix it easily, so have opted to restore and put future upgrades for MySql on hold. Only so much time to spend on these things and otherwise the XU4 running v159 is very stable so I’ll leave alone from now.

Happy with v6.* on my Z83.

John