MPR121 on Nanopi Neo 2


Just wondering anyone have any experience with using the MPR121 Capacitive touch controller on a NanoPi Neo 2 or any other SBC? I have try the following:

  1. Enable the i2c0 in /boot/armbianEnv.txt

  2. Compile the mpr121 module based on guide found in:
    How to Compile Just One Kernel Module

  3. Create this dts in /boot/overlay-user
    mpr121…txt (794 Bytes)

  4. Added mpr121 in the /boot/armbianEnv.txt

  5. reboot

and the module did load with dmesg:
[ 8.027084] mpr121_touchkey: loading out-of-tree module taints kernel.
[ 8.038693] mpr121_touchkey: module verification failed: signature and/or required key missing - tainting kernel
[ 8.040902] mpr121 0-005a: supply vdd not found, using dummy regulator

and lsmod did show mpr121 and created the device in /proc/bus/input/devices:

I: Bus=0018 Vendor=0000 Product=0000 Version=0000
N: Name=“Freescale MPR121 Touchkey”
P: Phys=
S: Sysfs=/devices/platform/soc/1c2ac00.i2c/i2c-0/0-005a/input/input0
U: Uniq=
H: Handlers=kbd event0
B: EV=100013
B: KEY=200000000003000
B: MSC=10

I ran i2cdtetect -y 0 and did show UU at address 0x5a, but when I run evtest on event0 , I got nothing.

I have checked that SDA/SCK/IRQ all have pull ups and the module is working when I tested it on a ESP32 (with pullup remove).

At this point I am a bit lost

If anyone have try this and work, help is very much appreciated.