Mounting public samba share on DD-WRT

After much faffing about and getting samba client error 22s, I felt the need to share this.

I was having problems mounting share VPN-MUSIC on my DD-WRT router at ip address 192.168.3.1, I had to change the offending line in /etc/fstab to

//192.168.3.1/VPN-Music /mnt/samba cifs guest,username=nobody,password=,iocharset=utf8,sec=ntlm,nofail,vers=1.0  0  0

The key parameter here is vers=1.0 which will cater for older shares.

I hope this will save someone some time.

Jason

I found the same solution as you did! https://dietpi.com/forum/t/dietpi-not-mounting-samba-share-after-update-to-v6-5/2115/2

:smiley: