Mjpg_streamer can't forward http input

I struggle to forward an http jpg stream to mjpg_streamer. It worked with motioneye though. It’s probably a misunderstanding of the command. You can find the command below I tried to use :

Creating a bug report/issue

Required Information

  • DietPi version | dev core 8 sub 13 rc 1
  • Distro version | bullseye
  • Kernel version | Linux DietPi 5.15.80-sunxi64 #22.11.1 SMP Wed Nov 30 11:23:00 UTC 2022 aarch64 GNU/Linux
  • SBC model | Generic Allwinner H5 (aarch64)
  • SD card used | SanDisk 16G

Additional Information (if applicable)

  • Software title | mjpg-streamer
  • Was the software title installed freshly or updated/migrated? intalled freshly

Steps to reproduce

/opt/mjpg-streamer/mjpg_streamer -i "/opt/mjpg-streamer/input_http.so -H http://192.168.1.12/stream -p 81" -o "/opt/mjpg-streamer/output_http.so -l http://192.168.1.12/stream -p 81"

Expected behaviour

Read http://192.168.12:81/stream as input and forward to current localhost ip which is http://192.168.1.6

Actual behaviour

MJPG Streamer Version.: 2.0
i: host…: http://192.168.1.12/stream
i: port…: 81
o: www-folder-path…: disabled
o: HTTP TCP port…: 81
o: HTTP Listen Address…: http://192.168.1.12/stream
o: username:password…: disabled
o: commands…: enabled
System error: Device or resource busy
Can’t allocate socket, will continue probing
: Invalid argument
System error: Device or resource busy
Segmentation fault

after -H it’s ip only 192.168.1.12 without anything it fixed it unfortunately there is another issue going on so the command should be

mjpg_streamer -i "input_http.so -H 192.168.12 -p 81" -o "output_http.so -p 8082