Minor Bug: Midnight commander line characters

After the update to 6.2 my mc forgot how to draw lines in putty. This can changed to e.g. from UTF-8 to ISO-8859-1 in Translation settings but then all dietpi menus get messed up. I did reinstall via dietpi-software and via apt to no avail.

Hi Narfel,

yes, notice this as well. Sorry, have miss to make a github issue for this.
Thanks for reminder.


edit: Done - Workaround for v6.2 available - Resolved for v6.3

Apologies, this was an issue our end in conjunction with a Dropbear (SSH Sever) bug.

Wow thank you, that was surprisingly complicated, wasn’t it? The workaround script for 6.2 from the github issue works like a charm for me (Pi0, putty).

Hi,

Thanks for your feedback. Nice to hear it will now work for you (with Dropbear SSH Sever).

For me?
No, I was only lecturer, protagonist, tester and assistant.
@Fourdee did the work and found a great solution for every locale language and running software.
But yes, it is not easy, by supporting a wide range of different platforms and many software title with a great spectrum.

I can’t take all the credit for this one. I used @MichaIng original idea with the previous profile.d template, works a charm :slight_smile:

And, as always, your valuable assistance @k-plan with this one :slight_smile:

Just in case you missed that: iptraf-ng and iftop suffer the same fate, as does wavemon and i guess other similar ncurses based apps. The same Translation switch like vom my first post works as well (with the same drawbacks). With the obvious disclaimer that I am using of course still on 6.2 the temporary fix didn’t look mc specific so i thought that would fix it for all.

Oh, and here’s a thank you you can*t wiggle yourself out. You pointed me (via the github issue) to Kitty. I use putty since forever never thought to check if there is a fork. So thanks for that as well :bulb: :slight_smile:

Found out that it is more widespread than i thought initially, other distros and hardware both brought the same garbled chars in either mc or other ncurses based programs. I could go around with setting Putty/Kitty Translation to anything BUT UTF-8 but none fixed both mc and other ncurses at the same time. All that playing around with locale settings didn’t help me, and neither did setting $TERM to anything. In the end i managed to realize that just using screen fixes all this. Since i was planning on using it anyway that’s my current fix for proper line characters.