Lxde headless mode

Hello, im facing with the lxde or vnc server tried with tiger and real vnc, i own a raspberry pi 4 is inserted in a robot so… the idea is to connect it via wifi so i can see desktop and camera,etc while moving.
the question is that i cant startx with lxde because not screen found, i need to connect it headless.
Already tried:

thats worked on raspbian but here not, please help me!
Thanks in advice

Did you tried using a VNC client app? VNC server should be running already if you installed via dietpi-software. There is no need to use startx manually or to force whatever HDMI mode on a headless system.

As an alternative to VNC, you can use xrdp

yes, im using realvnc

this is on solar putty:

As stated above already, there is absolutely no need to use startx. It has no influence into VNC. By default DietPi will start a virtual VNC session on boot at screen :1. Means, you need to add screen number to your IP address within RealVNC client: like See our online docs Remote Desktop Access Software Options - DietPi.com Docs


You are a genius!!!
thanks a lot!!!

i’ve simply added :1 in realvnc and voila!

1 Like

DEV’s really should offer a nomachine install

It is a bit resource heavy (and somewhat sluggish on SBC’s of limited processor capability[but it is able to change the settings on quality and fps that help]), but it seems to work 100%, even on an OPiOne and RPiZero2 with only 512mb RAM

You mean this on? Remote Desktop Access Software Options - DietPi.com Docs

1 Like

no…I mean sɔop ɯoɔ˙ᴉԀʇǝᴉp - suoᴉʇdO ǝɹɐʍʇɟoS ssǝɔɔ∀ doʇʞsǝp ǝʇoɯǝɹ

Lol…shoulda known better than to doubt the awesome DEV’s!!! :smiley: