Loaded kernel remains outdated after reboot

Yeah the warning only appears after the drive fully spins up. If it proceeds before that happens, then the same happens as with the USB stick. None have U-boot

In this situation, the messages are as expected. Since the firmware does not know where the u-boot boot configuration should ultimately be found, it logs all detection attempts, it is the user’s duty to ensure that it is at the desired location. If it can still not be found, one must investigate why this is so. Otherwise, these messages are only useful hints where the u-boot boot configuration can be placed.
Unfortunately, the search order and the locations are currently being determined at compile time, but it is already being discussed to be able to set this at runtime and to be able to offer the user an interactive selection of several configurations found.

Btw, our recent Odroid N2 and C4 images support petitboot and that way also USB boot OOTB, without the need to reflash the SPI first :slightly_smiling_face:.

Nice timing, i am expecting two brand new HDD. Will need instructions on how to do it when the time comes :tada:

I guess the new image needs to be used/flashed directly to HDD

Oh, I mean the HDDs will be used to upgrade my NAS storage. I am still running dietpi on the SSD connected via USB.

but it has still an SD card attached? Maybe I’m mixing thinks.

Yeah, it’s still booting using the SD card with the firmware you posted.

ok aim of the new image is to allow direct boot from USB device. Means, no SD card would be needed.

Here are instructions for updating the boot config and dietpiEnv.txt to make it compatible with petitboot: Odroid N2/HC4 | Add support for petitboot>USB boot · Issue #5634 · MichaIng/DietPi · GitHub

You should then be able to copy everything from the SD card the USB drive and remove the SD card. Not sure how you split it currently, I guess /boot is a mount from the SD card with boot config, kernel etc? Then it would be something like that:

cp -a /boot /boot_new
umount /boot
sed -i '/[[:blank:]]\/boot[[:blank:]]/d' /etc/fstab
rmdir /boot
mv /boot_new /boot

The SD card is completely empty aside from the single firmware file given to me, copied over via dd

I executed the code block linked on the PR and powered off the device, removed the SD Card and flipped the boot mode switch. It started petitboot but nothing else happens.

Does it detect the drive (shown at the top of the petitboot GUI) and is autoboot enabled? In case does it work to select the detected drive manually?

The menu only has a blank name at the top, but does list a device in system information (the only one, my SSD) on sda/sda1. I tried to boot it manually but I can’t find anything to make it boot.

But the /boot/boot.scr and everything is located on that SSD already, right?

maybe something went wrong. this is how the file looks like in VSC

That looks all correct. What does it do/say exactly when you manually try to select the USB partition for boot? petitboot is updated to latest version?

I ended up having a lot of kernel panics related to reading blocks on the external SSD, so I am now running a fresh dietpi install from a regular high endurance microSD. :wave: