lighttpd placeholder page blocking 443

Hey guys i had a nextcloud on IP:443 and wanted to move that for something else but now it won’t come up because it says the port is used by something else and by visiting my IP:443 i get to the placholder. does anyone know how to deactivate a specific site? could not find anything regarding this problem. if it is important, the xtcloud was installed locally and the ney thing i want to use is in docker. help would really be appreciated

Did you install Nextcloud via dietpi-software? Nextcloud would then be available at http(s)://IP/nextcloud and it is expected to see the placeholder page at http(s)://IP. You can change the port, but of course the new one must not be in use already. The following command lists used TCP ports and the using processes:

ss -tlpn

Did I understood correctly you want to move your Nextcloud into Docker? And Docker container should be reachable via port 80/443? If yes, you would need to remove the whole web server stack you had installed before or do some revers proxy

i had nextcloud via dietpi-software and could not get the ports to move so i reinstalled it with snapd (all locally) and i have the NGINX which i want to use as reverse proxy in docker and it should be up to be on port 443 but the container can´t start because lighttpd is blocking that page

not exactly, see my other answer for what i did and why. i am kind of new to this this is why i could not get the dietpi-software version of nextcloud to move. nontheless i suspect the exact same behavior if i could get it moving

You need to uninstall lighttpd via DietPi-Software or change port configuration for lighttpd to start on something else than 80/443. Depending on what you are trying to achieve.

The second one sounds like what I want to have. Do you know what I need to change and where it might be?

Server port is defined inside following file

/etc/lighttpd/lighttpd.conf

Thanks I found it. Unfortunately only port 80 can be edited in ln15 “server.port = 80” but port 443 is never mentioned in there.
Thanks btw for the patience. I do not seem too good at this

Your plan is to use a reverse proxy infront of lighttpd? An the reverse proxy should to HTTPS handling as well? If yes, you should disable HTTPS configuration on lighttpd. If this is the case, let me know and I will guide you.

Yup that’s exactly what I want

Try following

lighty-disable-mod dietpi-https
lighty-disable-mod dietpi-https_redirect
lighty-disable-mod dietpi-hsts
systemctl restart lighttpd

This should disable https usually.

Thanks a lot that worked