Libreoffice doesn’t start on debian 11

Hi all. I just upgraded my raspberri pi4 to debian 11, doing a clean install. I am still testing. I have installed libreoffice (via apt), but I can’t get it to start. I have tried dietpi on the raspberry, on a PC and on virtualbox but Libreoffice doesn’t work on any of them. With debian 10 it worked fine. I know that libreoffice is not part of the preconfigured dietpi software, but I hope someone can help me. thank you so much and Happy New Year.

what image you are running on the RPi4?

Required Information

  • DietPi version | cat /boot/dietpi/.version
  • Distro version | echo $G_DISTRO_NAME $G_RASPBIAN
  • Kernel version | uname -a
  • SBC model | echo $G_HW_MODEL_NAME or (EG: RPi3)

BTW: I tested the installation of Libreoffice on a RPi4B 64bit Bullseye and it was working ootb

apt install -t bullseye-backports libreoffice

sorry. I could not answer before. I forgot to mention that I was testing on a virtual desktop with tigervnc. With Debian 10 I was using realvnc in “shared desktop” mode (I think it came by default because I don’t remember setting it up). I have been able to verify that in a virtual desktop some applications do not work (for example libreoffice among others). I have installed realvnc and configured shared desktop mode and I can now run any graphical application remotely. thank you very much!!!

hmm that seems to be a challenge using VNC. Because if I switch to XRDP, no shared desktop mode is needed.

I have been trying different vnc servers and I was able to fix this issue by installing TIGHTVNCSERVER . Now I can start a virtual desktop and handle any application. Is there any difference between Tigervnc or Tightvnc in terms of security or performance? Thank you very much again

Sorry I don’t have any experience using Tightvnc and not able to answer your questions.