Kodi start error RPi 3 DietPi v8.2.2 ARMv6 ARMv8


I have installed DietPi and automatically upgraded to v8.2.2. I have tried both ARMv6 and ARMv8 releases. Clean install. The only piece of software installed is Kodi with autostart as root user.

In both cases (ARMv6 and ARMv8 releases) I am getting the same error messages:
failed to load driver vc4
failed to load driver kms_swrast
failed to load driver swrast

More detail in this pic:

cat /boot/config.txt

More info:

root@DietPi:~# cat /boot/dietpi/.version
root@DietPi:~# echo $G_DISTRO_NAME $G_RASPBIAN
bullseye 1
root@DietPi:~# uname -a
Linux DietPi 5.10.103-v7+ #1530 SMP Tue Mar 8 13:02:44 GMT 2022 armv7l GNU/Linux
root@DietPi:~# dpkg -l | grep kodi
ii  kodi                        2:19.3-1~bullseye                 all          Kodi Media Center (arch-independent data package)
ii  kodi-bin                    2:19.3-1~bullseye                 armhf        Kodi Media Center (binary data package)

Please, let me know if you need additioal details in order to better troubleshoot.

Thank you!

did you have done a reboot after activating dtoverlay=vc4-kms-v3d

can you have a look pls.

It looks like libgl1-mesa-dri is missing. Can you check:

dpkg -l libgl1-mesa-dri

In case:

apt install libgl1-mesa-dri

I just asked to have this added as dependency to the RPi kodi package, as it is with the Debian kodi package. Else we’ll install it via dietpi-software when Kodi is selected. Another thing I’m not 100% sure currently is whether libgles2 makes sense as well. Could be tested first without, then testing whether it enhances performance:

apt install libgles2

Added for next release, so in case the package is not patched, we are prepared: https://github.com/MichaIng/DietPi/commit/293f35b