[issue] Freezing DietPi

I was having some issues. My DietPi install keeps locking up/freezing.
Watchdog haven’t reacted in the slightest, it just stops.
Can’t access anything, no network connectivity, can’t enter anything from the terminal. Nothing.

Time between lockups are variable and not confined to any single operation. All random. It might be a day, it might be an hour. No way to tell.
I was running Wheezy for this on my RPi2, not realizing that I did.
Eventually I did and tried switching to Jessie. Did not get past boot. So to hell with it.

So I bought another RPi2, thinking that there were something wrong with the first one. But I have the same issue with
the new one.
Also I tried it on my RPi 1 and despite it freezing up that one time, it’s a hell of a lot more stable than being on RPi2
I tried switching SD-cards and formatting them.

I installed a stock Raspbian and it works like a charm.
But DietPi is fairly convenient and small, so I really want it, but can’t get past this issue.

The only thing I set up besides the applications that are provided by the dietpi-software script is OpenVPN and the Watchdog.

Does anyone have any ideas.
I’m going to check after work if the issue remains when I do a full (Not quick) format of the SD-card when I get
back from work.

Have you tried to use an other powersupply?

The one I use is brand new since the one I used previously was too weak.
It shouldn’t be the power supply.

I’m wiping the SD-card as we speak and will try again. I’ll be back with results.