intel NUC10 no networkcard

Hi there,

i’m using Dietpi for some time on raspberry pi’s and old pc’s and nuc’s

but i bought a new Intel NUC10 and i don’t get the internal network card to run.
googleing around i learnd this is a issue with debian also.

does anyoen know how to fix the issue?

Hi,

for testing purposes, did you tried to install plain Debian using Debian Netinst https://www.debian.org/CD/netinst/
Does it recognize your network card? Because DietPi is using Debian base image :wink:

Hi Joulinar,

jep, tried that and had the same result.
ubuntu seems to work according to google but dit’nt tried that.

Well if it’s not working on plain Debian, it will not work on DietPi either as DietPi is a set of scripts on top of Debian image.

i finally got to test debian 10 on the nuc 10.
here is a network driver that works.
now i don’t know how to get dietpi to find these

did you installed the driver yourself or was it already preinstalled?

As well you can try to install DietPi on top of your Debian system following this guide https://dietpi.com/docs/dietpi_sbc/#make-your-own-distribution