Installation Issue - 2GB SDcard, Raspberry Pi V1 B

Hi,

I’ve been enjoying using this excellent lightweight RPi OS on some of my larger SD cards.

I have a simple IoT project which is only a few KB so ideal for an old 2GB card, but the installer doesn’t fully complete. It fails after the reboot when it tries to update to the latest version giving an error message stating a min of 500MB is needed to continue. A quick df -h later I can see that a huge 1.4MB is used with only 484MB to spare.

I’ve tried few times and this issue seems to be consistent.

Does anyone have any ideas how to avoid this issue? Is there something I need to edit in the txt file before first boot?

Thanks.

Hi,

You can disable swapfile generation, after writing DietPi image, and, prior to booting device for 1st time in:

/boot/dietpi.txt

on your SD card. (please look at: DietPi-Automation)

. . .

# >> Misc Options -----------------------------------
#Size of dphys-swapfile to generate (MB)
#   0=Disabled | 1=auto (1GB-RAM = size) | 2+=manual
### Swapfile_Size=1 ## -default- ##
Swapfile_Size=0

. . .

Please have a look here:

After initial bootup and finishing installation, you can set swap file size via:

dietpi-config

170813-0001.gif

root@NanoPi-Neo:/# ls -lah /var/swap
-rw------- 1 root root 530M Jun 25 13:03 /var/swap

cu
k-plan

Thanks.

As you suggest preventing the creation of a swapfile leaves plenty of space for the installation process to fully complete. I can now use my old 2GB cards for some of my projects.