https on nextcloud doesn't work..

I’ve a orange pi board running nextcloud. It works fine, then I’m trying to enable https:// but not work…
I followed this steps:
1-installed and configured no-ip (running dietpi-config I see for NoIP=Online / Active) that’s fine
2- (install certbot and run dietpi-letsencrypt)
3- test my domain on (successfully)

but if I try to connect to my no way to get it!

any suggestion is appreciated

Weird, if the SSL test comes back ok, it should be functional.

Does the default website work, eg: ?

Lets take a look at your settings, are you running Lighttpd or Apache2 webserver?

the default website is not a “website”… I mean, I’m using dietpi on orange pi pc in my home-lan. Than shared (DMZ) the orange pi to the internet.
With no-ip i get this host: (seems works) (and I have a fixed public Ip from my isp)
I’m running apache2

Sorry, i meant the default index.htm page which gets installed by default.

Try connecting to your website without SSL to make sure its accessable externally:

Then do the same with SSL:

Also, can you paste/upload contents of the following files please:

  • /etc/apache2/apache2.conf
  • /etc/apache2/sites-available/* (eg: all files in this directory)