How to disable hdmi cec raspberry pi 4?

I would like to disable the HDMI cec, because when the raspberry pi 4 turns on, it always turns on the tv together…

google search revealed following Disable CEC - Raspberry Pi Forums

I already tried this solution it didn’t work for me
config.txt (2.5 KB)

Update: I tested this command and it worked


what did you already try? And what was the difference the to the solution now?

was it hdmi_ignore_cec=1 before and hdmi_ignore_cec_init=1 now?

yes I tried the command hdmi_ignore_cec=1 and it didn’t work and then I saw this command hdmi_ignore_cec_init=1 on this site and tried it, I don’t know why it worked, it was luck

1 Like

Looks like it is needed to even disable the initial CEC request. However it would expect it is already done by disabling the whole CEC function. Something to keep in mind. :roll_eyes: