How to add permission for motioneye to save videos on nfs shared folder

Little addition: motion nicely saves videos to /mnt/dietpi_userdata/motioneye/Camera1, because the folder is set to motion:motion as user:group. When changing this to /mnt/samba (setup with drive_manager) motion will not store anything, because the folder is owned by dietpi:dietpi. Any attempts in changing the ownership to motion or using chmod -R 777 /mnt/samba fail. Somehow drive_manager blocked the folder. Manually created files under root get saved and show on the NAS - which is proof that there are no problems on the side of the NAS or the link.
Any hint will get a big German DANKE!

Did you use the GID and UID flags to write to the samba share as a different user?

Samba don’t support Linux file system permissions at all. Therefore, we mount Samba shares with a fixed user dietpi:dietpi. This as well is the reasion why chmod -R 777 /mnt/samba is failing.

of course because user root is able to write into data directory of user dietpi

The Drive Manager does not lock or block anything. It is a tool to mount a drive and create configuration entries in /etc/fstab. Just take a look at this file and you should see the samba mount, user and group used to mount the share. You should also see the file system permissions settings. You can adjust the settings manually if necessary, or you can add the user motion to the user group dietpi. This would probably be the best option.

gern geschehen

PRIMA, that was the solution. With usermod -a -G dietpi motion added and with groups motion to
motion : motion video dietpi verified. After reboot everything worked.
Thanks again.

thx for sharing @EkkeNekkepenn

One small request. Pls try to stick to English. Even if I understood German, rest of community probably not :wink:

For now I translate your post