Homeassistant gave me a error with python

did a clean installation. did the installer put a old version of python on here or is this normal and it didn’t show up/see it before? it says Please upgrade Python to 3.12. this is using DietPi_NativePC-UEFI-x86_64-Bookworm_Installer. dietpi version 9.0.2 with 2024.2.2 home assistant.

This is not an issue, HA is working fine with current Python version. Anyway on next DietPi release, Python 3.12 will be supported for HA. See Home Assistant requires Python 3.12 · Issue #6906 · MichaIng/DietPi · GitHub

1 Like

I figured it was ignorable. thanks :slight_smile: