home assistant

Hello y’all,

I have been testing “home assistant”, At first install i managed to go to DIETPI-IP-ADDRESS:8123 and i noticed that home assistant already detected the gateway of my IKEA-lights (tradfri). But i just couldn’t connect to it (after entering the password of that gateway). Tried al sort of things (rebooted the dietpi/ikea-gateway). Reinstall the home assistant, manuall install the home-assistant.

I guess “home assistant” is still in beta (on the diet-pi) ?

ps: i am on V157 and i haven’t tried a clean install of dietpiv157 yet. (but i am going to)

Still no luck with the ikea-lights (see attachment). Did a clean install of dietpi, updated to latest version and installed home assistant.

error message in the home assistant.

I managed to switch my ikea-lights on/off with a python-script, So there’s no problem with the connection/dependencies/gateway/typos. Nevertheless the home assistant won’t connect to the ikea-gateway.

Dietpi and Ikea-gateway have been updated to the latest versions. (and i installed aiocoap)

ps: just read that a reset of the ikea gateway is something different than just power off/on. (lol). Will reset it the proper way!

nope, still no luck.

Things i have done:

reset gateway (the proper way)
edit configuration.yaml
auto discover ikea-gateway
Update HomeAssistant

Back to the forum off HomeAssistant

I just learned that the correct way of updating the homeassistant is:

sudo su -s /bin/bash homeassistant
source /srv/homeassistant/bin/activate
pip3 install --upgrade homeassistant