Home assistant update failing

Anyway plus run it again and share the whole output

Jep, not trivial to get this working with BerryBoot. It is horribly outdated (kernel-wise) in the meantime and the concept itself has major limitation, as we have no access to the boot config and kernel itself, i.e. it cannot be upgraded outside of the BerryBoot UI (if even possible there).

The kernel 4.14 is so old that it will have some issues with Bookworm, notably with WiFi at least, and of course has a large number of unresolved vulnerabilities, so that I wouldn’t recommend using it on any production server that is attached to the Internet.

HA however currently can only be installed on Bookworm. It might be possible on Bullseye again soon, but there are some quirks currently preventing this, which I do not fully understand yet, probably only some bug/mistake when dealing with Git: Unable to install package ha-av - #47 by MichaIng - Configuration - Home Assistant Community

1 Like

Still same error.
out.txt (44.9 KB)

I guess I will have to live with this version for sometime until I find a clear path for alternative. Thanks guys, you can close the topic.

Use 2 different SD cards :slight_smile:

one of the issues inside the error log

The pkg-config command could not be found.

Try following and run HA install again. Once failed, share the log again.

apt install pkg-config

Sure I will try. Meanwhile after berryboot upgrade, I am getting β€œReboot required” message after reboot as well. I will post the logs after installing pkg-config. Should I do that inside HA python environment or before?

 DietPi v8.21.1 : Reboot required
 - Device model : RPi 3 Model B (aarch64)
 - CPU temp : 59 Β°C / 138 Β°F : Running warm, but safe
 - LAN IP : (eth0)
 - MOTD : Check out the DietPi v8.21 release notes:

 DietPi Team     : https://github.com/MichaIng/DietPi#the-dietpi-project-team
 Patreon Legends : Camry2731, Chris Gelatt
 Website         : https://dietpi.com/ | https://twitter.com/DietPi_
 Contribute      : https://dietpi.com/contribute.html
 Web Hosting by  : https://myvirtualserver.com

 reboot          : A reboot is required to finalise a recent kernel upgrade

When I run diet-software, I was presented with following warning message

 Kernel modules for the loaded kernel at /lib/modules/5.10.43v64 are missing. This is most likely the case as of a    β”‚
β”‚ recently applied kernel upgrade where a reboot is required to load the new kernel.                                                                                                                                                       
β”‚ To assure that DietPi-Software can run successfully, especially when performing installs, it is required that you    β”‚
β”‚ perform a reboot so that kernel modules can be loaded ondemand. 
β”‚ There may be rare cases where no dedicated kernel modules are used but all require modules are builtin. If this is   the case, please create the mentioned directory manually to proceed.  
β”‚ Do you want to reboot now?

what is the version of the loaded kernel?

uname -a

I guess issue might be related to 32bit vs 64bit.

Now it is 64bit

but was 32bit before

Did you switched to 64bit by purpose? Because your entire system/userland is 32bit still. You just force a 64bit kernel mode. Which usually is a bad idea as it could cause other issues.

I didn’t switch on purpose. This message started showing up after berryboot upgrade. Berryboot has only one download for upgrade. I used that.

Should I rollback to older berryboot?

Which file you downloaded?


Guys, I found this thread which has similar issues reported. You have spent enough time and energy on this issue and decided not to pursue it further. Let me know if you still wish to continue troubleshooting this issue. Thanks again for such a amazing work!

Yes, the underlying problems with BerryBoot are always the same. In your case, the kernel image itself was updated, but not the kernel modules located below /lib/modules/. This StackExchange answer is very minimal and incomplete. Are there no official kernel upgrade docs for/from BerryBoot?
However, copying the content of /lib/modules/ from the image you downloaded over to the DietPi image should work.