High CPU load on fresh 1b installation

Creating a bug report/issue

Required Information

  • DietPi version | G_DIETPI_VERSION_CORE=8
    G_LIVE_PATCH_STATUS[0]=‘not applicable’

  • Distro version | bullseye 1

  • Kernel version | Linux pi1b 6.1.21+ #1642 Mon Apr 3 17:19:14 BST 2023 armv6l GNU/Linux

  • Architecture | armhf

  • SBC model | RPi B+ (armv6l)

  • Power supply used | USB power supply powering a 3b+ with attached 2.5HDD with no problems, sorry for not being more specific; no undervoltage warnings in dmesg

  • SD card used | SanDisk Cruzer Fit USB Drive; also Generic No-Name USB-Drive, no SD at all, using the bin.boot

Additional Information (if applicable)

  • Software title | none, fresh with nothing else

  • Was the software title installed freshly or updated/migrated only dietpi with no additions, installed from scratch

  • Can this issue be replicated on a fresh installation of DietPi? yes

← If you sent a “dietpi-bugreport”, please paste the ID here → did not

  • Bug report ID | echo $G_HW_UUID

Steps to reproduce

  1. Install dietpi, pihole, unbound;
    stop ( via systemctl)) all task related to php, unbound, pihole, still loads way over 1

  2. fresh install, after ~2h uptime : load average: 1.14, 1.38, 1.37

Expected behaviour

no such high load using a) fresh setup / b) using pihole/unbound

Actual behaviour

load is permanently way over 1, sometimes even 1.5, random load spikes (no top during this unfortenately during those) ; pi virtually dead as ping does not succeed, no ssh and DNS resolution also,

Extra details

using a WiFi-Dongle, this exact setup worked some time before, no undervoltage, iotop is mostly nothing as expected, so is top, the cpu is idle almost all the time until the system locks, where i can’t see why.

I found something related to a firmware bug (dating back to 2014 and fixed [tried rpi-update, no difference] in the pi, even tried that but bo difference.

New to the forum so

Hi to all :smiley:

hope to have provided all necessary information.

Anyway, thanks for an absolutely amazing distro (and any help) :slight_smile:

You said a 3B+, what variant of RPi do you have?

It’s a RPI 1

best would be to watch htop for CPU usage. Maybe you need to activate some more feature in htop to be able to see things like kernel modules as they are not shown by default.

Tried htop with K, but no difference. Nothing there.

“Load average” at the top right of htop shows the single-core average load for 1, 5 and 15 minutes. Please monitor htop a little longer. There must be some process peaking high once in a while. htop -d 0.5 may help (update list every 0.5 seconds) to better spot this, but is also raises the load caused by htop itself significantly.

Yeah, single core is going to have higher than what you would expect since everything has to flow thru that one processor (thus the beauty of multiple core processors)

as Michalng says…give it a bit to calm down

It never goes below 1 which it definitely should. Especially if there is nothing using the CPU according to htop. Htop -d 0.5 only shows itself and nothing else using the CPU and still the load is around 1.5 to 1.8.

Did you ever do an

# apt update && apt upgrade -y
# reboot


As dietpi does this on installation and it is an absolute fresh installation, yes. But for good measure, yes I did it manually too.