Hanging at Starting DietPi-Autostart custom script...


My DietPi hangs at the beginning.

[ OK ] DietPi-Services | start : influxdb
[ OK ] DietPi-Services | start : grafana-server
[ OK ] DietPi-Services | start : cron

How can I debug this issue further?

you could start sharing your script. And does it work if you execute the script manually? Maybe your program needs to be started in background mode. Similar to this https://dietpi.com/forum/t/autostart-with-2-programs/6429/14

The script is nearly empty.

# DietPi-Autostart custom script
# Location: /var/lib/dietpi/dietpi-autostart/custom.sh

exit 0

So it seems like these are systemd services.

This is what I have inside cron.service.

Description=Regular background program processing daemon
After=remote-fs.target nss-user-lookup.target

ExecStart=/usr/sbin/cron -f $EXTRA_OPTS


I’m a little bit confused on what you are trying to do actually. The custom.sh script seems to be empty and there is nothing in that could be started. And why are you looking for the cron service? This has nothing to do with starting custom.sh. It is the standard cron service of a Debian system.

I did not do anything specifically. I just installed influxdb and grafana via dietpi-software and that thing started to appear.

ok and why do you believe the DietPi-Autostart custom script is hanging? If you don’t select it as autostart option, it is not active/started/used.

Because when I power up my Pi, that is the thing that I see on my Monitor. It is my first post here in this discussion. Oh, I see, I forgot to include that line sorry. Here is what I see:

[ INFO ] Starting DietPi-Autostart custom script...
[ OK ] DietPi-Services | start : influxdb
[ OK ] DietPi-Services | start : grafana-server
[ OK ] DietPi-Services | start : cron

what is the actual setting in dietpi-autostart? If there is no plan to use any custom script, option 0 is the correct one.

Current AutoStart Option: 17

I do not even know, how did that happen. I only want Grafana and Influx services to start at the beginning.

pls switch to option 0. This way the autostart custom script will not be triggered.

If I select the option “0” the problem disappears. However, the problem exists even with option “7”.

I would like to select 7 if possible.

that looks like some scripts that will be executed during login. Can you try using option 0 and login manually? Does this work? Using option 7 will not invoke any dietpi autostart script.