FriendlyElec NanoPi R4SE (emmc) installation problem


Just to know if anybody tried to install DietPi on a FriendlyElec R4SE successfully.

I followed their wiki:
but the only way to install it is via FriendlyWRT.

After installation no sign of boot. No system led flashing.
Everything dead.

DietPi boot successfully from SDcard anyway.


1 Like

did you boot of the SD card and tried to flash image using dd to emmc?

Thanks for your reply.

Yes I did it.
Boot from SD, logged via SSH and DD to emmc.

No way: It won’t boot.

Did you detach the SD card when trying to boot from eMMC?

The only difference between R4S and R4SE is the onboard eMMC, right?

Probably the device tree of our current image is too old. I’ll create a new image.

Images up: Index of /downloads/images

1 Like

Thanks but still not working.

I have purchased 3 units of the R4SE.

All face the same troubles.

I have downloaded this latest version.
“Burned” an Micro SD 16GB
Plugged, switched on with a 5A power supply to be sure enough power.
It boot perfectly !
I did minimal setup and then start the problem.

As soon I finished and arrive to ‘root@dietpi:’ I type “shutdown -r now” and device is gone.
No sign of reboot.
The SYS light keep heartbeating
The WAN light disappear
I waited 10 minutes… still the same… no reboot, no ping to it, etc…
I unplugged, waited 1 minute, replugged the power cable and device return to the same status of “dead”, the one after I did a reboot.

I unplugged the microsd, I reflashed it again and replugged and restarted and again device boot successfully

I remade a setup minimal again and it went fine.
Again “reboot” and device didn’t reboot and went “zombie”

I tried 5 different SD card… which 4 worked, in all the 3 units I have.
All three units have same ending… zombie after the first reboot

This to me is the worst FriendlyElec device yet, although it look so solid and well made from outside…

PS: Forget it to write to eMMC… I tried but no way it boot…


There is a device tree for R4S only, no dedicated one for R4SE, same with U-Boot, so unless both explicitly have eMMC included, it is expected that this does not work, at least not to boot from. I’m not sure about other minor hardware differences between R4S and R4SE, so there may be other subtile issues.

However, it does boot at first, including network, obviously, so it should be able to continue work after reboot.

This indeed sounds like it hangs on shutdown. The SYS LED should switch off for some seconds during early boot stage.

The WAN LED works for you already? I did just yesterday enable it in our image build scripts and a patch in DietPi dev branch. With our current image, both Ethernet LEDs shouldn’t do anything. Or do you mean the ones at the back side, below the Ethernet ports?
And btw, at least on my R4S, eth0 (which is configured on first boot and by dietpi-config) is the “LAN” port, not the “WAN” port.

Did you use our latest image, from the link above? Could you try to go through first boot and setup again, but not reboot, instead:

dmesg -l emerg,alert,crit,err
cat /etc/network/interfaces

To check whether there are kernel errors and network is configured as expected, at best DHCP on eth0 (“LAN” port), the default on first boot, to rule out that it’s just a network issue.

Do you have a UART adapter, to monitor late shutdown and early boot logs on serial console?