Fixed: Unable to mount samba/cifs share on Pi

Fixed: see solution in my reply below

I am trying to mount samba share on my Pi running Dietpi. So I ran the drive_manager to add the file share but it always fails with mount errors 95 and 13. The share is hosted on a Mac running latest OS X 11.5 with the built in samba server. I tried to use drive_manager and get this error message. Here is the error message:

I tried a whole bunch of commands using mount.cifs and mount -t cifs, many different combinations of sec= and vers=; all to no avail. Result being mount error 13, permission denied.

Here is a page from apple talking about SMB. If you can't mount SMB share hosted by a Mac bound to Open Directory - Apple Support

Here are two messages from dmesg:

[12945.107771] CIFS: VFS: \\ Dialect not supported by server. Consider  specifying vers=1.0 or vers=2.0 on mount for accessing older servers

[ 7823.928905] CIFS: No dialect specified on mount. Default has changed to a more secure dialect, SMB2.1 or later (e.g. SMB3.1.1), from CIFS (SMB1). To use the less secure SMB1 dialect to access old servers which do not support SMB3.1.1 (or even SMB3 or SMB2.1) specify vers=1.0 on mount.

Let me know what other information/logs are required and I am happy to provide them. I feel this is more difficult than it should be.

Solution: Requires the the “Windows File Sharing:” feature to be enabled on the host Mac. I don’t know why the Mac needs this. It gives a message about this feature reducing security in the manner the password must be stored. Not sure how much less secure. I avoided this option before because of this message and just thinking that this wouldn’t be needed for linux as it is for windows. I should have tried it earlier. If I were to want to use this feature for longer than just testing purposes, which is what I am; I would look into how much less secure this makes the system.

This feature is located in the system preferences/ sharing/ file sharing/options menu.

Well this is a permission issue. Are you sure you specified correct user/password and used the correct server path/folder?

Hey thanks looking at this, it gave me energy to go back and look at it with fresh eyes. Turns out it is a stupid option on the host Mac that is required to make it work, “Windows File Sharing:”. I describe it in an edit at the bottom of my original post. I was tired and broke two cardinal rules: exhaust all options and try the easiest thing first.

thx for sharing.