FIXED - Odroid N2+ audio problem


I’m using DietPi v8.1.2 on Ondroid N2+. I enabled default sound card configuration and also Auto-conversion
Image 001.png
But speaker test will always fail on “invalid argument”
Image 2.png
I have tried to reset configuration, enable / disable auto-conversion, “-c 2 argument”, but without success

configuration is following :

root@DietPi:~# cat /etc/asound.conf
pcm.!default {
type plug
slave.pcm {
type hw
card 0
device 0

ctl.!default {
type hw
card 0

I can see many no backend DAIs enabled for fe.dai-link-0 error messages everytime I execute speaker-test. Maybee just some configuration or drivers are missing ?

Any suggestions how to proceed ? Thanks in advance for your help !

Edit : seems like amixer settings were missing, after adding its OK

amixer sset ‘FRDDR_A SINK 1 SEL’ ‘OUT 1’
amixer sset ‘FRDDR_A SRC 1 EN’ ‘on’
amixer sset ‘TDMOUT_B SRC SEL’ ‘IN 0’
amixer sset ‘TOHDMITX I2S SRC’ ‘I2S B’
amixer sset ‘TOHDMITX’ ‘on’
amixer sset ‘FRDDR_B SINK 1 SEL’ ‘OUT 2’
amixer sset ‘FRDDR_B SRC 1 EN’ ‘on’
amixer sset ‘TDMOUT_C SRC SEL’ ‘IN 1’
amixer sset ‘TOACODEC SRC’ ‘I2S C’
amixer sset ‘TOACODEC OUT EN’ ‘on’
amixer sset ‘TOACODEC Lane Select’ ‘0’
amixer sset ‘ACODEC’ ‘255’
amixer sset ‘FRDDR_C SINK 1 SEL’ ‘OUT 3’
amixer sset ‘FRDDR_C SRC 1 EN’ ‘on’
amixer sset ‘SPDIFOUT SRC SEL’ ‘IN 2’

Did you apply the latest live patch from a few days ago? dietpi-update

yes I have already latest DietPI version. But as I explained , problem was in missing amixer settings. We can close this thread as it is already solved.

When you select the now available onboard audio options from dietpi-config sound card selection, it applies the required amixer settings automatically, at least it should. If this does not, please report back.


I have tried all dietpi-config possibilities

  • HDMI
  • 3,5mm
  • hw 0,0 or 0,1 or 0,2

with auto conversion ON / OFF but nothing helped me. Fortunately I found on another forum this thread which saved me :