FileBrowser with https connection using duckdns

I have recently started using dietpi on my Zero 2 W.

The installation and setup have been no problem so far. However, what I can’t get to work is to access the FileBrowser via an https connection.

To what works:

  • FileBrowser is accessible in the local network via its IP and port 8084.
  • FileBrowser is reachable over a http connection via duckdns and port 8084
  • Letsencrypt has created a ssl certificate for the duckdns domain.

Can someone explain to me what I need to set up to connect FileBrowser via https?

Thanks for your time in advance!

best to my knowledge, FileBrowser themselves did not support HTTPS ootb. You would need to setup a revers proxy like Nginx and activate SSL on it.

Hey @Joulinar, I’ve read that article and tried setting up a reverse proxy with nginx. I have this working and I can get routed to a custom path - like /filebrowser - but the page never loads. In the GitHub issues page, people set “baseURL” to their path but this option is done with a json config. Does the Dietpi FileBrowser support this?

Theoretically this would be possible, I guess. You should be able to set base url using the command line tool filebrowser config set - File Browser

did you manage to get it working i’m also trying to but to no afail

what steps you did? and what is not working? Some more details would be helfpful.

Hi Joulinar,

i use nginx as reverse proxy to acces a homer static webpage on a with links to

these are working
PC: webmin, adguard, prowlarr, sonarr, radarr, lidarr, readarr, qbittorrent, vaultwarden and jellyfin
PI: webmin

still trying to get working are File Browser, Home Assistant, OpenWRT and Dietpi-Dashboard

files browser on gives me the three dots page

i made a files.conf in


location /files {
proxy_redirect / /files/;

i have been searching for the *.json config file but there is none
so i read Authentication Method - File Browser on the filesbrowser website
but i do not know where and how i need to enter the cmds listed

i have tried on /opt/filebrowser/filebrowser but i got an error

if you could explain how to make an config.json file that would be more helpfull for me because
the cmdline its like abracadabra to me :rofl:


Hi Joulinar,

i could not get it to work using the dietpi install so i uninstalled this and used this tutorial

works perfect

We don’t use the json file. Our configuration has been done using FileBrowser command line tool filebrowser config set - File Browser

Just tested on 2 demo system. One was hosting FileBrowser and the other was Nginx. Working without any issues

  1. FileBrowser system
# login as root
cd /mnt/dietpi_userdata/filebrowser
systemctl stop filebrowser.service
/opt/filebrowser/filebrowser config set -b /file
systemctl start filebrowser.service
  1. Nginx system
nano /etc/nginx/sites-dietpi/file.conf


location /file {
                proxy_pass http://192.168.x.x:8084;

save config and restart Nginx

systemctl restart nginx.service
  1. done

wow thanks i will try this tomorrow

@Joulinar Hello Sir, I’m attempting to change the default port of Filebrowser from 8084 to 80 to allow usage over the internet with my domain. I successfully completed port forwarding and set all necessary router rules, and the default Apache page is now accessible on the internet. However, when I try to access Filebrowser, it is not working. I used the following config:

and restart the filebrowser service nothing happens I even tested by uninstalling the apache and retrying everything but to no avail. Please help.

You can not run two services on the same port. You would need to stop apache (which is listening on port 80 and 443) and then start filebrowser on that port. Or you use a reverse proxy, so filebrowser is still running on port 8084 but you can reach it then via your domain, like

That’s why I uninstalled Apache and tried everything again but it didn’t work. :pray:

Oh I overread that.
Can you show journalctl -u filebrowser and ss -tulpn

1 Like

Ok I will need to test but can do this late evening only. Give me some time.

1 Like

Sir, I tried many things but unfortunately it didn’t bind to port 80/443 somehow. It will easily bind to any port like 8081, 8082, 6423…
So I ended up using the apache reverse proxy. Now I just need to add /files at the end of my url. and that’s it. I think I should use a simple Js file to redirect to /files from the Home page immediately once someone visits the main URL. That’s what I can think of as a temporary solution for now.

You can also set up a redirect from the web root to /files or even make the /files path the web root, with apache.
So you don’t need to use JS as a workaround.

problem on port 80, it is a privileged port and not everybody is allowed to use it.

Feb 04 22:06:12 DietPiR5S filebrowser[3286]: 2023/02/04 22:06:12 No config file used
Feb 04 22:06:12 DietPiR5S filebrowser[3286]: 2023/02/04 22:06:12 listen tcp bind: permission denied

Therefore filebrowser is going to fail if you try to use this one. To allow port 80, some additional settings would be needed on service config

  1. run dietpi-services
  2. select filebrowser service
  3. select Edit
  4. confirm the question if needed
  5. add following into the new file inside [Service] section
  1. save file
  2. leave dietpi-services` now
  3. restart filebrowser service
  4. done
Feb 04 22:09:47 DietPiR5S filebrowser[3467]: 2023/02/04 22:09:47 No config file used
Feb 04 22:09:47 DietPiR5S filebrowser[3467]: 2023/02/04 22:09:47 Listening on [::]:80
root@DietPiR5S:~# ss -tulpn | grep LISTEN
tcp   LISTEN 0      1000*    users:(("dropbear",pid=368,fd=4))
tcp   LISTEN 0      4096               *:80              *:*    users:(("filebrowser",pid=3467,fd=7))
tcp   LISTEN 0      1000            [::]:22           [::]:*    users:(("dropbear",pid=368,fd=5))