File System not expanding


I recently installed DietPi on 3B using a 128gb card. Awesome piece of software! My only issue right now is my ext4 partition is only reporting the size as 33.5GB. I have tried resize in Drive_Manager and it does not help. If I fdisk -l it shows as 119.5G? How can I fix this?



many thanks for your request. Maybe there is something blocking the extension of the ext4 partition. An option to have a look to the SD card would be using GParted tool. One of the best tools I know to manage drives and partitions. You can create a Live USB Stick and boot GParted on your desktop computer. There you could plug the SD card and check what’s going on. As well it will allow you to mange the SD card (rezise).

Thanks for the help

Ran GParted (It refused to boot on a surface pro 3) When I ran a “Check” on the partition I got;

rootfs: recovering journal
Superblock needs_recovery flag is clear, but journal has data
Run Journal anyway? yes

roots:Warning: Filesystem still has errors

I am just going to format and start from scratch. DietPi makes it really easy!

Thanks for the help!

Well, my problem is all on my end. Fake SD card. I have had it sitting around for 5 years, this is the first time I have used it to hold more than 5gb of data. Moral of the story, test any card bought off of Amazon.

Thanks for all the help, Diet Pi is awesome.

strange that GParted was not booting on your surface pro 3. I just tested it with my surface pro 3 and it was working well. And sorry to hear that you had bad sectors on your SD. I hope it’s better once started from scratch with a new SD card. cheers

Ya Surface was refusing to boot usb, tried 2 different sticks.

With a 16gb card everything is working well. The 128gb card was setup as a test machine. I wanted to see how the 3B would handle Plex for my situation, and for me it works well. Permanent setup is a 16gb card with a 4TB NTFS external drive. So far so good

Thanks again for all the help

I guess you did but still like to ask :sunglasses:

Did you followed this guide to boot your surface from usb stick