Failed apt-get upgrade after v140

After doing dietpi-update to version 140 I can’t seem to fix these broken packages. This is running on my Odroid c2

Fetched 290 kB in 8s (32.9 kB/s)
Reading package lists... Done
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 libc-bin : Depends: libc6 (> 2.23) but 2.19-18+deb8u6 is installed
 libc-dev-bin : Depends: libc6 (> 2.23) but 2.19-18+deb8u6 is installed
 libc6-dev : Depends: libc6 (= 2.23-1) but 2.19-18+deb8u6 is installed
 libdevmapper1.02.1 : Depends: libc6 (>= 2.22) but 2.19-18+deb8u6 is installed
 libmono-csharp4.0c-cil : Depends: libc6 (>= 2.22) but 2.19-18+deb8u6 is installed or
                                   libc6.1 (>= 2.22) but it is not installable or
                                   libc0.1 (>= 2.22) but it is not installable
 libmono-microsoft-build-engine4.0-cil : Depends: libc6 (>= 2.22) but 2.19-18+deb8u6 is installed or
                                                  libc6.1 (>= 2.22) but it is not installable or
                                                  libc0.1 (>= 2.22) but it is not installable
 libmono-microsoft-build-tasks-v4.0-4.0-cil : Depends: libc6 (>= 2.22) but 2.19-18+deb8u6 is installed or
                                                       libc6.1 (>= 2.22) but it is not installable or
                                                       libc0.1 (>= 2.22) but it is not installable
 libmono-microsoft-build-utilities-v4.0-4.0-cil : Depends: libc6 (>= 2.22) but 2.19-18+deb8u6 is installed or
                                                           libc6.1 (>= 2.22) but it is not installable or
                                                           libc0.1 (>= 2.22) but it is not installable
 libmono-microsoft-build4.0-cil : Depends: libc6 (>= 2.22) but 2.19-18+deb8u6 is installed or
                                           libc6.1 (>= 2.22) but it is not installable or
                                           libc0.1 (>= 2.22) but it is not installable
 libmono-oracle4.0-cil : Depends: libc6 (>= 2.22) but 2.19-18+deb8u6 is installed or
                                  libc6.1 (>= 2.22) but it is not installable or
                                  libc0.1 (>= 2.22) but it is not installable
 libmono-posix4.0-cil : Depends: libc6 (>= 2.22) but 2.19-18+deb8u6 is installed or
                                 libc6.1 (>= 2.22) but it is not installable or
                                 libc0.1 (>= 2.22) but it is not installable
 libmono-system-drawing4.0-cil : Depends: libc6 (>= 2.22) but 2.19-18+deb8u6 is installed or
                                          libc6.1 (>= 2.22) but it is not installable or
                                          libc0.1 (>= 2.22) but it is not installable
 libmono-system-windows-forms4.0-cil : Depends: libc6 (>= 2.22) but 2.19-18+deb8u6 is installed or
                                                libc6.1 (>= 2.22) but it is not installable or
                                                libc0.1 (>= 2.22) but it is not installable
 libmono-system4.0-cil : Depends: libc6 (>= 2.22) but 2.19-18+deb8u6 is installed or
                                  libc6.1 (>= 2.22) but it is not installable or
                                  libc0.1 (>= 2.22) but it is not installable
 libmono-xbuild-tasks4.0-cil : Depends: libc6 (>= 2.22) but 2.19-18+deb8u6 is installed or
                                        libc6.1 (>= 2.22) but it is not installable or
                                        libc0.1 (>= 2.22) but it is not installable
 mono-4.0-gac : Depends: libc6 (>= 2.22) but 2.19-18+deb8u6 is installed or
                         libc6.1 (>= 2.22) but it is not installable or
                         libc0.1 (>= 2.22) but it is not installable
 mono-csharp-shell : Depends: libc6 (>= 2.22) but 2.19-18+deb8u6 is installed or
                              libc6.1 (>= 2.22) but it is not installable or
                              libc0.1 (>= 2.22) but it is not installable
 mono-devel : Depends: libc6 (>= 2.22) but 2.19-18+deb8u6 is installed or
                       libc6.1 (>= 2.22) but it is not installable or
                       libc0.1 (>= 2.22) but it is not installable
 mono-mcs : Depends: libc6 (>= 2.22) but 2.19-18+deb8u6 is installed or
                     libc6.1 (>= 2.22) but it is not installable or
                     libc0.1 (>= 2.22) but it is not installable
 mono-xbuild : Depends: libc6 (>= 2.22) but 2.19-18+deb8u6 is installed or
                        libc6.1 (>= 2.22) but it is not installable or
                        libc0.1 (>= 2.22) but it is not installable
 monodoc-base : Depends: libc6 (>= 2.22) but 2.19-18+deb8u6 is installed or
                         libc6.1 (>= 2.22) but it is not installable or
                         libc0.1 (>= 2.22) but it is not installable
E: Unmet dependencies. Try using -f.

I tried doing these commands to fix it but nothing seems to be working:
apt-get -f install,
apt-get clean
apt-get update
apt-get dist-upgrade

Hi,

Thanks for the report.

There was a patch for v140 that resolves a known issue with broken packages deps, however, it appears you have a setup combination that is requiring newer versions of the package. So that patch has failed on your system.
https://github.com/Fourdee/DietPi/issues/653

Please run the following:

apt-get install libc6 --reinstall

Then attempt to use apt-get again.

If the errors still occur, we’ll need to track down what software installed pulled in the newer package. Please send us a bug report that will contain this information for us to check:
https://dietpi.com/forum/t/send-dietpi-a-bug-report/421/1 have you manually installed any software outside of DietPi-Software?

I made a bug report :slight_smile:
Reference CODE: 467c8cf4-9d34-4470-919d-19d86d6dca87-0

When trying to run the command apt-get install libc6 --reinstall, the same error occurs.

root@Odroid ~ # apt-get install libc6 --reinstall
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 libc-bin : Depends: libc6 (> 2.23) but 2.19-18+deb8u6 is to be installed
 libc-dev-bin : Depends: libc6 (> 2.23) but 2.19-18+deb8u6 is to be installed
 libc6-dev : Depends: libc6 (= 2.23-1) but 2.19-18+deb8u6 is to be installed
 libdevmapper1.02.1 : Depends: libc6 (>= 2.22) but 2.19-18+deb8u6 is to be installed
 libmono-csharp4.0c-cil : Depends: libc6 (>= 2.22) but 2.19-18+deb8u6 is to be installed or
                                   libc6.1 (>= 2.22) but it is not installable or
                                   libc0.1 (>= 2.22) but it is not installable
 libmono-microsoft-build-engine4.0-cil : Depends: libc6 (>= 2.22) but 2.19-18+deb8u6 is to be installed or
                                                  libc6.1 (>= 2.22) but it is not installable or
                                                  libc0.1 (>= 2.22) but it is not installable
 libmono-microsoft-build-tasks-v4.0-4.0-cil : Depends: libc6 (>= 2.22) but 2.19-18+deb8u6 is to be installed or
                                                       libc6.1 (>= 2.22) but it is not installable or
                                                       libc0.1 (>= 2.22) but it is not installable
 libmono-microsoft-build-utilities-v4.0-4.0-cil : Depends: libc6 (>= 2.22) but 2.19-18+deb8u6 is to be installed or
                                                           libc6.1 (>= 2.22) but it is not installable or
                                                           libc0.1 (>= 2.22) but it is not installable
 libmono-microsoft-build4.0-cil : Depends: libc6 (>= 2.22) but 2.19-18+deb8u6 is to be installed or
                                           libc6.1 (>= 2.22) but it is not installable or
                                           libc0.1 (>= 2.22) but it is not installable
 libmono-oracle4.0-cil : Depends: libc6 (>= 2.22) but 2.19-18+deb8u6 is to be installed or
                                  libc6.1 (>= 2.22) but it is not installable or
                                  libc0.1 (>= 2.22) but it is not installable
 libmono-posix4.0-cil : Depends: libc6 (>= 2.22) but 2.19-18+deb8u6 is to be installed or
                                 libc6.1 (>= 2.22) but it is not installable or
                                 libc0.1 (>= 2.22) but it is not installable
 libmono-system-drawing4.0-cil : Depends: libc6 (>= 2.22) but 2.19-18+deb8u6 is to be installed or
                                          libc6.1 (>= 2.22) but it is not installable or
                                          libc0.1 (>= 2.22) but it is not installable
 libmono-system-windows-forms4.0-cil : Depends: libc6 (>= 2.22) but 2.19-18+deb8u6 is to be installed or
                                                libc6.1 (>= 2.22) but it is not installable or
                                                libc0.1 (>= 2.22) but it is not installable
 libmono-system4.0-cil : Depends: libc6 (>= 2.22) but 2.19-18+deb8u6 is to be installed or
                                  libc6.1 (>= 2.22) but it is not installable or
                                  libc0.1 (>= 2.22) but it is not installable
 libmono-xbuild-tasks4.0-cil : Depends: libc6 (>= 2.22) but 2.19-18+deb8u6 is to be installed or
                                        libc6.1 (>= 2.22) but it is not installable or
                                        libc0.1 (>= 2.22) but it is not installable
 mono-4.0-gac : Depends: libc6 (>= 2.22) but 2.19-18+deb8u6 is to be installed or
                         libc6.1 (>= 2.22) but it is not installable or
                         libc0.1 (>= 2.22) but it is not installable
 mono-csharp-shell : Depends: libc6 (>= 2.22) but 2.19-18+deb8u6 is to be installed or
                              libc6.1 (>= 2.22) but it is not installable or
                              libc0.1 (>= 2.22) but it is not installable
 mono-devel : Depends: libc6 (>= 2.22) but 2.19-18+deb8u6 is to be installed or
                       libc6.1 (>= 2.22) but it is not installable or
                       libc0.1 (>= 2.22) but it is not installable
 mono-mcs : Depends: libc6 (>= 2.22) but 2.19-18+deb8u6 is to be installed or
                     libc6.1 (>= 2.22) but it is not installable or
                     libc0.1 (>= 2.22) but it is not installable
 mono-xbuild : Depends: libc6 (>= 2.22) but 2.19-18+deb8u6 is to be installed or
                        libc6.1 (>= 2.22) but it is not installable or
                        libc0.1 (>= 2.22) but it is not installable
 monodoc-base : Depends: libc6 (>= 2.22) but 2.19-18+deb8u6 is to be installed or
                         libc6.1 (>= 2.22) but it is not installable or
                         libc0.1 (>= 2.22) but it is not installable
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

I do have quite a big of softwares installed outside of dietpi-software. Sonarr, Couchpotato, Jackett, and rtorrent/rutorrent (I’ve installed these before they were implemented into dietpi). When I manually installed Sonarr I had to install mono which I think could be the problem. I’m just not sure what I can do to fix the issue.

Don’t worry about this. I started a fresh install of v140 and now everything is good. You can close this thread :slight_smile:

Excellent, thanks for letting us know :slight_smile: