# fail2ban nextcloud won't start

**URL:** https://dietpi.com/forum/t/fail2ban-nextcloud-wont-start/4593
**Category:** Troubleshooting
**Created:** [4 November 2020 12:25 UTC](https://dietpi.com/forum/t/fail2ban-nextcloud-wont-start/4593 "2020-11-04T12:25:52Z")
**Posts on this page:** 6
**Page:** 1

<div class="post-metadata">

### Author: ![DietRK](https://dietpi.com/forum/letter_avatar_proxy/v4/letter/d/b2d939/32.png) [@DietRK](https://dietpi.com/forum/u/DietRK)
#### Post date: [4 November 2020 12:25 UTC](https://dietpi.com/forum/t/fail2ban-nextcloud-wont-start/4593/1 "2020-11-04T12:25:52Z")

</div>

After configured fail2ban for nextcloud i’m getting this errors

systemctl status fail2ban.service

```nohighlight
root@DietPi:~# systemctl status fail2ban.service
● fail2ban.service - Fail2Ban Service
   Loaded: loaded (/lib/systemd/system/fail2ban.service; enabled; vendor preset:
 enabled)
   Active: failed (Result: exit-code) since Wed 2020-11-04 13:19:46 C
ET; 22s ago
     Docs: man:fail2ban(1)
  Process: 4587 ExecStartPre=/bin/mkdir -p /var/run/fail2ban (code=exited, statu
s=0/SUCCESS)
  Process: 4588 ExecStart=/usr/bin/fail2ban-server -xf start (code=exite
d, status=255/EXCEPTION)
 Main PID: 4588 (code=exited, status=255/EXCEPTION)

Nov 04 13:19:46 DietPi systemd[1]: Starting Fail2Ban Service...
Nov 04 13:19:46 DietPi systemd[1]: Started Fail2Ban Service.
Nov 04 13:19:46 DietPi fail2ban-server[4588]: Failed during configuration: Bad
value substitution: option 'action' in section 'nextcloud' contains an interpola
tion key 'action_mw1' which is not a valid option name. Raw value: '%(action_mw1
)s'
Nov 04 13:19:46 DietPi fail2ban-server[4588]: Async configuration of server fai
led
Nov 04 13:19:46 DietPi systemd[1]: fail2ban.service: Mai
n process exited, code=exited, status=255/EXCEPTION
Nov 04 13:19:46 DietPi systemd[1]: fail2ban.service: Fai
led with result 'exit-code'.

```

nano /etc/fail2ban/jail.conf

```nohighlight
[nextcloud]
enabled = true
port = 80,443
protocol = tcp
filter = nextcloud
maxretry = 3
logpath = /var/log/nextcloud.log
action = %(action_mwl)s

```

---

<div class="post-metadata">

### Author: ![Joulinar](https://dietpi.com/forum/user_avatar/dietpi.com/joulinar/32/57_2.png) [@Joulinar](https://dietpi.com/forum/u/Joulinar)
#### Post date: [4 November 2020 13:09 UTC](https://dietpi.com/forum/t/fail2ban-nextcloud-wont-start/4593/2 "2020-11-04T13:09:39Z")

</div>

Hi,

looks like the action you have set is not accepted. Where did you get the config from?

```nohighlight
value substitution: option 'action' in section 'nextcloud' contains an interpola
tion key 'action_mw1' which is not a valid option name. Raw value: '%(action_mw1
)s'

```

---

<div class="post-metadata">

### Author: ![DietRK](https://dietpi.com/forum/letter_avatar_proxy/v4/letter/d/b2d939/32.png) [@DietRK](https://dietpi.com/forum/u/DietRK)
#### Post date: [4 November 2020 13:32 UTC](https://dietpi.com/forum/t/fail2ban-nextcloud-wont-start/4593/3 "2020-11-04T13:32:21Z")

</div>

copied it from here  
[https://www.ksite.de/nextcloud-mit-fail2ban-absichern/](https://www.ksite.de/nextcloud-mit-fail2ban-absichern/)

---

<div class="post-metadata">

### Author: ![Joulinar](https://dietpi.com/forum/user_avatar/dietpi.com/joulinar/32/57_2.png) [@Joulinar](https://dietpi.com/forum/u/Joulinar)
#### Post date: [4 November 2020 13:41 UTC](https://dietpi.com/forum/t/fail2ban-nextcloud-wont-start/4593/4 "2020-11-04T13:41:04Z")

</div>

probably a typo. It should be

> action = %(action\_mwl)s

With L like Lima.

On you error message it looks like a 1 (one)

---

<div class="post-metadata">

### Author: ![DietRK](https://dietpi.com/forum/letter_avatar_proxy/v4/letter/d/b2d939/32.png) [@DietRK](https://dietpi.com/forum/u/DietRK)
#### Post date: [5 November 2020 10:56 UTC](https://dietpi.com/forum/t/fail2ban-nextcloud-wont-start/4593/5 "2020-11-05T10:56:32Z")

</div>

i tried it several times,  
only if comment out action , failban runs

```nohighlight
[nextcloud]
enabled = true
port = 80,443
protocol = tcp
filter = nextcloud
maxretry = 3
logpath = /var/log/nextcloud.log
#action = %(action_mwl)s

```

fail2ban-client status

```nohighlight
Status
|- Number of jail:	3
`- Jail list:	dropbear, nextcloud, sshd

```

Maybe a problem of Nextcloud \> 16 ?

---

<div class="post-metadata">

### Author: ![Joulinar](https://dietpi.com/forum/user_avatar/dietpi.com/joulinar/32/57_2.png) [@Joulinar](https://dietpi.com/forum/u/Joulinar)
#### Post date: [5 November 2020 14:03 UTC](https://dietpi.com/forum/t/fail2ban-nextcloud-wont-start/4593/6 "2020-11-05T14:03:54Z")

</div>

well your problem is the line action = %(action\_mwl)s within your jail.conf file. Best to my knowledge, this is to send email notification. [https://wiki.archlinux.org/index.php/fail2ban#Receive\_an\_alert\_e-mail](https://wiki.archlinux.org/index.php/fail2ban#Receive_an_alert_e-mail)

But I guess this is not configured on your F2B installation. Found another guide how to setup F2B and Nextcloud [https://www.allerstorfer.at/fail2ban-fuer-nextcloud/](https://www.allerstorfer.at/fail2ban-fuer-nextcloud/)

Btw: nextcloud.log is located at /mnt/dietpi\_userdata/nextcloud\_data/nextcloud.log by default.
