Ethernet 100 deactivated LAN

Hello.

Today I set my Ethernet adapter from Auto to 100. It was probably a mistake.

I assumed that my Raspi could do Ethernet 100.
No connection was possible, the LAN LEDs all stayed off. At least there is a 100 next to the LED.

Fortunately, I was able to repair the problem with the HDMI cable and keyboard by selecting “Auto” in the LAN settings. Known problem?

Greetings :slight_smile:

Required Information

  • DietPi version | G_DIETPI_VERSION_CORE=8
    G_DIETPI_VERSION_SUB=5
    G_DIETPI_VERSION_RC=1
    G_GITBRANCH=‘master’
    G_GITOWNER=‘MichaIng’
  • Distro version | buster 1
  • Kernel version | Linux DietPi 5.10.103+ #1529 Tue Mar 8 12:19:18 GMT 2022 armv6l GNU/Linux
  • SBC model | RPi B (armv6l)

Additional Information (if applicable)

  • Bug report ID | cd10dac7-58ef-443a-83e3-6313f17843c9

Did you also set the speed to 100Mbps on the other side of the link or only on the RPi?

RaspberryPi is connected to a Gigabit switch. The switch is connected to a Fritzbox 7590 with a gigabit connection.

that was not the question. Question was if the Switch is able to auto detect the link speed?

Did a quick test on my RPI 1 and RPi3B+. Both set to 100M inside dietpi-config

root@DietPi1:~# ethtool eth0 | grep Speed
        Speed: 100Mb/s
root@DietPi1:~#
root@DietPi3:~# ethtool eth0 | grep Speed
        Speed: 100Mb/s
root@DietPi3:~#

Both are shown correctly on my switch

The thing is that when you set the speed and duplex manually, the other side (your switch) must also be set with the same settings. That happens because when you set one side manually it doesn’t negotiate with the other side the speed and duplex but expects it to work with the same settings.
If in doubt, leave it to auto speed and duplex.

Hi, it is a “8-Port-Gigabit-Ethernet-Unmanaged-Switch Netgear GS108GE”

Unfortunately, I have no setting options here. I thought the device recognises what speed the client wants, as long as it is not higher.

Greetings

The switch cannot recognize the speed of the devices connected to it if you don’t use the auto negotiate.

1 Like

Usually also there shouldn’t be a need to manually reduce the link speed. What was the reason in your case? The option was added since there was specifically of SBC which in the past had issues with GiB link.

I thought, why leave it on “AUTO” when I can also set max speed (100). That was the only reason :wink:

I thought that otherwise it would settle between 10 and 100, depending on the load.

It doesn’t work “in the between”. If for some reason (bad cable, interference) it cannot work at 100/Full, it will try 100/Half or 10/Full or 10/Half.

1 Like

as stated by @trendy . The network settings are not dynamic and they are not going to change until you set something manually or some physical components breaks. Setting it to auto usually result in the max possible connection. However, the network might not be the limiting factor on a RPi B (armv6l). It’s quite an old model with lover performance anyway :wink:

2 Likes