Encountering issues running Matrix Synapse maintenance tools on DietPi

Creating a bug report/issue

Required Information

  • DietPi version | G_DIETPI_VERSION_CORE=8
  • Distro version | bullseye 0
  • Kernel version | Linux hostname 5.15.84-v8+ #1613 SMP PREEMPT Thu Jan 5 12:03:08 GMT 2023 aarch64 GNU/Linux
  • SBC model | RPi 4 Model B (aarch64)
  • Power supply used | The official RPi 4 Power Supply
  • SD card used | Using USB3 Hard Drive

Additional Information (if applicable)

  • Software title | Matrix Synapse
  • Was the software title installed freshly or updated/migrated? Fresh installed during end of 2021 year
  • Can this issue be replicated on a fresh installation of DietPi? Yes

Steps to reproduce

  1. Git clone and cargo build the synapse_auto_compressor tool in GitHub - matrix-org/rust-synapse-compress-state: A tool to compress some state in a Synapse instance's database
  2. Run synapse_auto_compressor as described in their repo README using the correct information.
    – which is ./synapse_auto_compressor -p postgresql://user:pass@localhost/synapse -c 500 -n 100 and this info comes from the dietpi-generated /mnt/dietpi_userdata/synapse/homeserver.yaml.d/00-dietpi.yaml
  3. Tool should run correctly. Please note that this same process has been tested & worked successfully on a non-DietPi Matrix Synapse server.

Expected behaviour

  • The synapse_auto_compressor should correctly run on the Matrix Synapse instance.

Actual behaviour

  • The synapse_auto_compressor is failing to work correctly.
  • I have tested the same process outlined here on a Vanilla Debian 11 install currently running Matrix Synapse, and after entering the correct information, it worked.

Extra details

  • All of the postgresql database user and location are located in /mnt/dietpi_userdata/synapse/homeserver.yaml.d/00-dietpi.yaml as we see in the dietpi-software script
  • Using cargo and rustc 1.64.0 on the DietPi server

Did you build it for ARM or try to install a binary package?

Maybe I overlooked it but did you shared any error message or similar?